This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Robert 5 months, 1 week ago.

Assigned support staff: Diego Pereira.

Author Posts
April 26, 2019 at 10:43 am #3689877

Robert

Hi,
when I'm trying to translate a pdf file with media translation, I get this error. With all other image files it worked fine.

April 26, 2019 at 3:33 pm #3692033

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @robert, welcome to the WPML support Forum!

I'm not sure if the media translator is compatible with PDF files. In addition, it works only for images in the_content () field of WordPress.

Could you give us more details about your needs? E.g. you need to download a link with different files on each language. Maybe we can find another way to translate the file.

All the best,
Diego

April 28, 2019 at 11:27 pm #3699087

Robert

Hi Diego,

but it worked before. It stopped working with one of the last updates.

My needs are:
I have an pdf in German and one in English as Download for a different pages. The Files are integrated with ACF.
So on the German side I have a page with a custom pdf Download file and on the English page I need the English pdf.

As on the WPML page: https://wpml.org/documentation/getting-started-guide/media-translation/#translating-attached-images-and-other-media you write about images and other media.

April 29, 2019 at 8:26 pm #3706523

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I sent some instructions to replicate the website through a private message (previous answer).

Please let me know if it worked for you. If so, please send us clear instructions on how to see/reproduce the issue.

Kind regards,
Diego

April 29, 2019 at 8:31 pm #3706545

Robert

Hi Diego,
thanks for the private message, but I have a test environment for that situation, so if u want I can give u access. How to provide u with access credentials?

April 30, 2019 at 6:24 pm #3714271

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks, it will be very helpful. I enabled the private field, please send us the credentials of the test website.

IMPORTANT: Please backup your site first before making any change, this is important for security reasons.

Kind regards,
Diego

May 7, 2019 at 1:43 pm #3758615

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thank you. I did several tests but did not found a solution so far. i'm double-checking this with my team and will send you a feedback soon.

Kind regards,
Diego

May 10, 2019 at 1:38 pm #3785069

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

The issue with the media translator ("failed to open the image editor" error) seems to be related to some server configuration. I made a copy of the site on my local server using duplicator and it worked correctly. Usually this is related to the PHP GD Library, but apparently it is active on your server.

I was able to use a different PDF in translation using the manual editor:
- Go to the edit screen of the post (original language).
- Turn off the "Use WPML's Translation Editor" on the right sidebar
- Select your editor preferences and save
- Upload the new PDF file to the translation and save

It worked on this post:
- hidden link
- hidden link

Could you please check if this is a suitable solution for you?

Kind regards,
Diego

May 14, 2019 at 11:18 pm #3811023

Robert

My issue is resolved now. Thank you!