Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 28 replies, has 4 voices.

Last updated by Andreas W. 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
October 25, 2019 at 2:44 am

nikolajW

Hello,

the images with text of different languages are not showing up in the foreign language.

See video for demo:
hidden link

Regards

October 25, 2019 at 8:16 pm #4829923

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I took a look at your WordPress Dashboard and confirmed the Divi image has the same german image for both languages, it sounds like a compatibility issue, please, proceed this way:

  • Install the theme/plugin in a clean installation and reproduce the problem in this new installation. So we can isolate it and do some testing without the interference of server settings or other plugins
  • After this, I will check the problem in this new installation and look for a quick solution
    If I can not find a solution, I will forward the problem to our compatibility team.
  • The compatibility team will do some more testing and will contact the product author to fix the issue

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the (theme/plugin) to this test install, setup it the same way as in your website (using the same options) and create some dummy content to reproduce the issue. Please note that we only need the (theme/plugin) and the related functionality, you don't need to setup a entire website or clone your existing site. The fewer plugins the better.

After that, please send us clear steps on how to see/reproduce the issue on this test install. We will run some tests.

Please, let me know when you are ready, thank you for your collaboration, have a nice day.

October 26, 2019 at 1:13 am #4830439

nikolajW

Media Translation menu isn't there.

Activating all plugins didn't help.

October 29, 2019 at 12:23 am #4843371

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Please click to setup WPML at WordPress Dashboard > Languages of the sandbox environment and match your WordPress installation where the issue is seen, it will help us to determine if we have a compatibility issue here.

October 29, 2019 at 2:07 am #4843445

nikolajW

It works on the sandbox.

How to troubleshot on my installation?
I config the media in the same way and added a image to a new site ("test"), but no change.

Regards

October 30, 2019 at 12:51 am #4852297

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I checked the sandbox test site and indeed it works, please, proceed with the following troubleshooting steps:

1 - Make sure all your WPML related plugins and your Divi theme are updated to their latest version.

2 - Disable all the plugins except the WPML related ones and see if the issue is gone, if so enable one by one untill the possible culprit plugin is found.

3 - Temporary disable any possible server cache you might have.

Please, let me know if it helps, have a nice day.

October 30, 2019 at 4:16 am #4852495

nikolajW

Hey, the issue is not gone.
I guess it is a configuration issue.
But what did I configure wrongly?

October 30, 2019 at 8:18 pm #4859253

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to investigate your specific settings into details, so I will be able to provide you with a more accurate and detailed answer, for that, please consider: I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

November 1, 2019 at 9:02 am #4868967

nikolajW

Hey, there are no fields to enter the FTP infos.

November 1, 2019 at 3:15 pm #4871913

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Please, try it again, I have enabled the private fields again, so you can safely provide these access details. Thank you for your collaboration and patience, have a nice day.

November 4, 2019 at 8:30 am
November 5, 2019 at 6:55 pm
November 5, 2019 at 6:56 pm #4893013

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks.

November 8, 2019 at 12:42 am #4910523

nikolajW

Site is migrated.

November 8, 2019 at 7:12 pm #4916359

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I could manage to solve your issue in a local debugging with these steps:

1 - In your WordPress Dashboard > Media change to the english language using the top admin bar language switcher.

2 - Find the translated image (proven-expert) which is not being showed in your website frontend and delete it.

3 - In your WordPress Dashboard > WPML > Media Translation upload the translated image again, make sure it has a different name, so, instead of 'proven-expert-DE' you can try something like 'proven-expert-EN'.

You can see the results of this approach at: hidden link

Please, let me know if it works for you, have a nice day.