This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 12 replies, has 4 voices.

Last updated by Andreas W. 1 month ago.

Assigned support staff: Andreas W..

Author Posts
May 24, 2020 at 5:28 pm #6205161

drosophila

Hello,

I would like to translate the Home of the web (made with Beaver Builder). There are images with links to product category.
When I tried to translate it, the links of the images are not in the translation page (see screen capture attached).

I have an english product category created (it is in this link: hidden link).

I have a picture in the home linked to the category in spanish (see the screen capture to know what image Im talking about). If I see the home in spanish, the image links to the spanish category, not to the english category.
How can make that the link to the category in the english version home links to the english version category?

Thank you very much

May 26, 2020 at 11:18 am #6218347

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

Thank you for contacting WPML Support.

Could you please provide me with access, as you have a web-auth activated?

For this, I would need to request temporary access (WP-Admin and FTP) to your site
– preferably to a test site where the problem has been replicated if possible –
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

Best Regards
Marcel

May 27, 2020 at 10:13 am #6228097

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

thank You, could you please deactivate "WPS Hide Login" or write my the endpoint /wp-admin is having now?

Thank You

Best Regards
Marcel

May 27, 2020 at 10:15 am #6228099

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

I deactivated it over FTP, so don't worry about my last reply 🙂

May 27, 2020 at 11:32 am #6228795

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi again,

I checked the compatibility code for beaver builder and we have already an existing link target translation for the image element.

I added the element on another page (Blog) and here I'm able to translate the link target: hidden link

But, this doesn't work on your start page. I compared both image elements and they are identical. Do you have any modifications/custom code active which could block rendering this correctly on your start page?

Best Regards
Marcel

May 27, 2020 at 12:17 pm #6229251

drosophila

It is not a problem of the home page.
I copied the row of pictures in the same "blog" page, and when translating, they do not appear.
I created a new row, with the same images, and when translating, they do not appear.
I create an image, and when translating, it does not appear.
Could you check the page blog?
I dont understand what could be happening.

May 27, 2020 at 2:12 pm #6230015

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

That's really weird. Could you please try as a test do recreate one image from scratch with URL on a NEW/empty page? Does that work?

May 27, 2020 at 5:31 pm #6231787

drosophila

I created two new pages:

- BBtest: I create the row with the images with urls. When translating, it does not work.
- BBtest-2: I put only an image with url. When translating, it does not work.

You can see the pages and check.

May 29, 2020 at 8:08 am #6247013

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

My colleague Marcel is sadly not availble at the moment which for I am glad to take care of your request.

As far I can see, the issue is, that the translation will not save inside of the WPML Classic Translation Editor, correct?

I made some adjustments on the test-site:

- Adjusted the Translation Settings for Beaver Builder Post Types and Taxonomies to be "translatable"

- Adjusted the Multilingual Content Setup to set Page Builder related system fields to "copy" in order to have the same Page Builder settings on all translated pages.

- Fixing default language assignment in WooCommerce Multilingual for all product category, and tag bases as for Shipping Classes, as they were assigned to the wrong default language (English) which might come to issue, once we translate.

- Beaver Builder -> Translated "fila-imagenes-borrar" global row for the mentioned section

Take not that any Beaver Builder Content, like Templates, Rows, Columns, Modules and Categories will need to be translated.

Apart from that I updated our plugins to the latest version and enabled WP Debug but did not find any error.

Now, the issue that still occurs is that the WPML Translation Editor will not confirm that the translation is saved and redirect to the WordPress page Editor, but the translations are actually working.

This issue even occurs when running the site only with Beaver Builder (Standard Edition), WooCommerce, and WPML plugins.

I can offer you to migrate a copy of the website to our test server for further investigation but firs tplease reach out ot your hosting provider and ask them please to:

- set the PHP Memory Limit to 512M
- adjust max_input_vars to the value 5000 or higher.

Those settings should to be taken inside the php.ini file of the currenlty used PHP version which should be located on the server. Anyhow, please ask your hosting company first, as on specially on cheap or shared hosting those settings might be restricted for users.

Further, please ask your hosting company if they could update mySQL on the server to MySQL 5.6 or above according to the minimum requierments to run WordPress with WPML.

The currently used version of mySQL 5.5.5. might also be a culprit for this issue.

Once this is set please change the WP Memory Limit to 256M.

Your current values are:

PHP MemoryLimit 192M <-- This should be higher than the WP Memory Limit (php.ini)
WP Memory Limit 192M <--- wp-config.php

Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.

If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.

I hope this will solve the issue with our Classic TranslatioN Editor, otherwise we will keep investigation and work on a solution for you.

Kind regards
Andreas

May 30, 2020 at 12:27 pm #6255907

drosophila

It is complicated.
I make the following steps. Tell me how you see them:

I translated the Home page and I went to Dashboard > WPML > Settings > Translate Link Targets and clicked the button 'Scan now and adjust links'. Then I save in Settings -> Permanent links, and it works.
There is not any external link, so I understand this way I can get the result I am looking for. Dont you think?

May 31, 2020 at 8:34 am #6258915

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

It seems that this could be a compatilbity issue. I did receive a second issue related to category pages with a 404 when using Beaver Builder.

Could you please install Beaver Builder (Standard Editor) on this test-site and assist me with trying to recreate the issue on this new WordPress install:

hidden link

Please leave me a note with the results for further assistance.

Kind regards
Andreas

May 31, 2020 at 10:42 am #6259253

drosophila

I installed Beaver Builder in the test site, and created a page with images. You have to configure the WPML to check. Tell me if you need something more.

June 3, 2020 at 5:41 am #6279497

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I was not able to recreate the issue on a new WordPress install while using our latest plugin version for WPML Multilingual CMS. Your site has been updated as well and the issue seems solved.

In your example you are using images with internal links from the media gallery. Those links will not be translated inside the WPML Classic Translation Editor.

Example:
hidden link

Could you please let me know if you still see another issue on the testing site?

Kind regards
Andreas