This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 3 voices.

Last updated by johnC-7 4 months, 3 weeks ago.

Assigned support staff: Radu.

Author Posts
May 2, 2019 at 9:13 am #3723139

Patrick

I am trying to:
I change the content of an Beaver Builder Block. After i saved the block the URL to the images changes to two different kind of URLs. This only happens in the translated post / page.

Before:
hidden link

After:
hidden link../wp-content/
hidden link

Link to a page where the issue can be seen:
I corrected it in the page, but it happens again.
hidden link

I expected to see:
No change of the URL.

Instead, I got:
A changed image url.

May 2, 2019 at 12:33 pm #3724515

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Patrick,

Thank you for reaching out the WPML support!

Is there any chance that you could give me access to the dashboard area so I can try to translate the image and see what happens, please? Also, you said that you corrected this for the TEUFELSBERG - ABOUT PLACES AND RUINS page. Can you tell me how did you do that? How are you correcting the image url? I just need a few more details so I can make check things out and see what's going on.

Thanks,
Radu

May 6, 2019 at 6:12 am #3744887

Patrick

Hi Radu,
i think my description was not the best. Sorry.
I think it is not an image translation Problem.

- We translated a post from german to english with WPML.
- We used the WPML Translation Manger.
- The problem occurs when we try to change the content via Beaver Builder.
- We use the Beaver Builder "Text Editor" Module.

Here are some Screenshots:

Before editing:
2019-05-06_07-53-28.png

While editing:
2019-05-06_07-53-49.png

After pressing the save button in the "Text Editor" Module.
2019-05-06_07-54-03.png

This also happens if i switch to Text Mode and Back to Visual Mode in the Module
2019-05-06_07-56-36.png

This is how the image URLs are looking in Text Mode:

<img class="alignnone wp-image-782" src="hidden link../wp-content/uploads/2018/11/teufelsberg-2361484_640-300x200.jpg" alt="" width="541" height="360" />

<img class="alignnone size-medium wp-image-935" src="hidden link../wp-content/uploads/2018/12/cover-teufelsberg-400x600-200x300.jpg" alt="" width="200" height="300" />

Many thanks for your help

Best regards
Patrick

May 6, 2019 at 6:16 am #3745009

Patrick

Sure i can give you access to the website. But after i post my answer. I cant get back to private answer in this support ticket. Do you need to answer first, or is there a trick. 😉

May 8, 2019 at 8:07 am #3764415

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Patrick,

Thank you very much for the details about the problem. They are really helpful. Now, please give me access to the dashboard area (I already set your reply to be private) and a link to the post from your screenshots. This way I'll be able to check things out a bit closer and see what's going on.

Thanks,
Radu

May 9, 2019 at 6:41 am #3773357

Patrick

We did another Test the last days.

We created 2 pages and translated them.

One of them had the described problem, the other one not.
These are the Pages: "80475 BB Test", "80475 BB Test Original".

The one without the problem ("80475 BB Test Original") uses a non translated url for the image. The other one uses a translated url and the problem apears.

And we don't understand why there is a dieffernce and why the translated url has problems.

🙁

Best Patrick

May 13, 2019 at 3:58 am #3794883

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Patrick,

I checked both 80475 BB Test and 80475 BB Test Original pages a few times but I couldn't see the problem that you described. The link of the images is the same in both languages. If the problem is still available, is there any chance that you can create a short video, please? You can use a free online tool like hidden link and I think that this way I'll be able to see the issue you described.

Thanks,
Radu

May 13, 2019 at 5:26 pm #3800959

Patrick

Hi Radu,
yes the problem still exist. I don't know why the example isn't working anymore.
The problem is confirmed by the beaver builder support. They build the example, but they can't help.

But the example i mentioned in my second post is still working.
I made a screen recording with this example.

hidden link

Hope the video helps.

Best regards
Patrick

May 13, 2019 at 5:28 pm #3800961

Patrick

Please also look at mit Reply #3744887. I described it there.

May 15, 2019 at 12:14 pm #3816271

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Patrick,

I had another look at both pages that you mentioned previously (80475 BB Test and 80475 BB Test Original) and tried to move from the Visual mode to Test and back, and everything worked very well. I also edited both pages (in English and Deutsch) and things worked well. For example, on this page hidden link I added one more point at the end of the text and for the English version I added two more points hidden link. Can you tell me if you were editing the translation (English version) using Beaver Builder or by using translation management (the option from the right side of this page hidden link), please?

Thanks,
Radu

May 15, 2019 at 1:42 pm #3817179

Patrick

Hi Radu,
did you watched the Video?

Please copy the video link in your browser. ( hidden link )
Its is not working in the embeded lightbox. I didnt know the forum ist embeding the link.

We did the first translation in the language manager. After that we used beaver builder to edit the the content. Thats where we got the problem.

You can still see the problem at this page:
hidden link

This is also the page i described in #3744887 and the one i used in the video.

We can do a google meet. Maybe its the best to show you the problem.

Best regards
Patrick

May 17, 2019 at 8:37 am #3832379

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Patrick,

I understood from your second message, the one where you attached a couple screenshots, what the problem was about. However, since this is happening only when editing a translation page, please use the option from WPML to edit the translation by pressing the pencil button from the right side of this page: hidden link This way, the link of the images won't be broken. So, can you try to edit the page this way and tell me if the images work fine this time, please?

Thanks,
Radu

May 28, 2019 at 6:32 am #3903047

Patrick

Hi Radu,
many thanks for your help.

Unfortunately, the problem is not satisfactory for my client.
He also wants to work with the Beaver Builder in the translated version.

I will continue to work on a solution my customer is satisfied with.

Best regards
Patrick

May 28, 2019 at 6:33 am #3903049

Patrick

...

July 23, 2019 at 8:39 pm #4268855

johnC-7

Hey Patrick,

We're having the same issue as you with this and have not been able to get any answers from either WPML support or Beaver Builder support.

Have you found any kind of solution you can share?