Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:image missing after translation

Solution:i have solved the problem the mistake was that i have not select the option Enable RTL (right to left support) in theme setting when i select this option now its working fine,perfect

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Bobby 3 years, 3 months ago.

Assigned support staff: Bobby.

Author Posts
September 25, 2018 at 7:21 am #2762793

kamranS

when i make translation using WPML plugin and save everything then images are not displayed after translation,all other text is translated but images not shown after translation.please guide me why is happen and how can i fix it.reply me fast please thanks

September 26, 2018 at 3:09 am #2765877

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

please go to WPML->Settings->Post Types Translation-> Media -> set to Translatable - use translation if available or fallback to default language

let me know your results

NOTE: Please make sure you update your WPML plugin and its add-ons to their latest versions.

September 26, 2018 at 6:58 am #2766069

kamranS

hi.. but i have not these options (WPML->Settings->Post Types Translation-> Media) when i go to WPML there are some other options but not same like this. i don't know my WPML plugin is updated or not can you tell me how to update wpml so i can update it first. thanks.
you can see the the options under WPML in screen short

wp.JPG
September 26, 2018 at 4:58 pm #2768235

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

you can go to Plugins->Add new->Commercial -> and update WPML from within there.

or you can go to https://wpml.org/account/downloads/

and update manually

to do a manual update please follow these steps:

1. Backup your database – see for example: http://wordpress.org/extend/plugins/wp-db-backup/

2. Deactivate the existing WPML plugin and add-ons.

3. Delete the plugin files – this does not delete your translations. You will simply delete the plugin files from you "wp-content/plugins" folder NOT the database records.

4. Download the updated plugins from our servers and upload them to the plugin directory.

5. Activate the WPML plugin and add-ons.

let me know your results

September 26, 2018 at 8:03 pm #2768573

kamranS

hi, i have updated wpml and its components successfully. after that i follow your instructions. go to WPML->Settings->Post Types Translation-> Media -> set to Translatable - use translation if available or fallback to default language but still it not works.. then in seting--> custom filed translation i select accommodation images to copy (accommodation images--> copy).
now after translation images are shown in smaller size but not shown in large size and move as a slide that is happen in default English language.
in default English language images shown in large size and move as a slide at top and in bottom images shown in small size also. check the screen short and also visit hidden link and click on hotels to see the difference in both language English and Arabic... need some more help thanks

nno.JPG
ggm.JPG
September 26, 2018 at 8:39 pm #2768704

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

it looks like the slider is actually not functioning , if you keep clicking on the left button it will show one picture and then blank again.

there is a possibility that the slider does not support RTL.

which slider are you using for this ?

September 27, 2018 at 6:45 am #2769457

kamranS

hi.. yes when clicking on left side one image shown then blank i don't know why all images not shown. i think slider that used in my theme is slider revolution.
but if you notice slider images on home page at top working fine but but that come after translation not working fine..help me more to fix this problem please thanks

September 27, 2018 at 8:18 am #2769686

kamranS

hi, i have solved the problem the mistake was that i have not select the option Enable RTL (right to left support) in theme setting when i select this option now its working fine,perfect..thanks

September 27, 2018 at 6:31 pm #2771586

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

i am glad the the issue has been resolved

Kind regards,
Bobby