This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.15 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: Images are missing from the german copy of the page using Beaver Builder

Solution: Go to WPML -> Settings -> Post Types Translation -> And set Media to 'Translatable - use translation if available or fallback to default language'

Relevant Documentation:

This topic contains 5 replies, has 2 voices.

Last updated by Carlos Rojas 1 year ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 9, 2018 at 7:07 am

udoS-2

I am trying to: edit the english version of my site with BeaverBuilder

Link to a page where the issue can be seen: hidden link --> D-Startseite EN-Version

I expected to see: a copy of the german site

Instead, I got: a copy of the german site but many images are missing

October 10, 2018 at 2:25 am #2802634

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.
I will do my best to help you solve this issue.

I went to WPML -> Settings -> Post Types Translation -> And set Media to 'Translatable - use translation if available or fallback to default language'

I would like to ask you to translate the English version of the homepage again and add the images. If the issue persists after the step above then I kindly ask you to install Translation Management plugin and try it again.

Could you tell me if the issue persists?

Kind regards,
Carlos

October 10, 2018 at 9:32 am #2803669

udoS-2

Hello Carlos,

thank you very much for your answer. How can I delete the current english translation and make a new copy with the German contents?

Kind regards

Melanie

October 10, 2018 at 8:10 pm #2805708

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Melanie,

To delete the english version of the homepage you need to follow this steps:
- Go to Pages -> Change to English -> Send the homepage page to the trash -> Go to the trash and delete the page permanently.

Please let me know if you need further assistance and I will be more than happy to help.
Best regards,
Carlos

October 15, 2018 at 6:39 am #2816339

udoS-2

My issue is resolved now. Thank you!

October 16, 2018 at 12:54 am #2819015

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Melanie,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos