If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by arnoldS-2 1 year, 5 months ago.

Assigned support staff: José Arcos.

Author Posts
June 10, 2018 at 10:37 am #2403346

arnoldS-2

I am trying to:

Translate this page in English;

hidden link

Link to a page where the issue can be seen:

The images do not load up in Hebrew;

hidden link

I expected to see:

Instead, I got:

June 12, 2018 at 9:08 am #2407369

José Arcos

Hello, thank you for contact us. I will try to do my best to help you.

After our latest update, we have some issues with WPML Media, we have reported two of them here:
- https://wpml.org/2018/06/known-issues-with-media-translation-for-wpml-4-and-upcoming-solutions/
- https://wpml.org/forums/topic/images-of-products-in-secondary-language-will-not-show/

Are any of these the scenario of your error? If so, we will share a quick solution as soon as possible.

Thank you.

June 12, 2018 at 11:09 am #2407856

arnoldS-2

I tried the Beta Fix Version 4.3.0-b.1 on my local testing site and it did not resolve the issue. The product image intially loads in the second language but then disappears. Please make sure this is the issue your developers are dealing with. thank you.

June 14, 2018 at 2:07 pm #2413650

José Arcos

Hello again, I can see that the issue is fixed now (see screenshot), the images are loading in both languages. Do you still see the issue? Is it a different one?

Thanks for the info.

June 14, 2018 at 3:35 pm #2413785

arnoldS-2

No it isn't. I just restored to a prior state before your plugin updates

June 15, 2018 at 10:38 am #2415288

arnoldS-2

It is unfortunate this thread is moving very slowly and still no progress to a solution;

I tried the Beta Fix Version 4.3.0-b.1 on my local testing site and it did not resolve the issue. The product image intially loads in the second language but then disappears. Please make sure this is the issue your developers are dealing with. thank you.

I restored to a previous versions of your plugins to temporarily (solve) the issue.

To solve this issue the images should load up in both languages running ALL versions of WPML.

What is the status with your plugins? When can I update them?

Please note the following;

With following version, there are no issues;
WooCommerce Version 3.3.5
Updated WooCommerce Multilingual Version 4.3 
WPML Media Version 2.2.3
WPML Multilingual CMS Version 3.9.4
WPML String Translation Version 2.7.3
WPML Translation Management Version 2.5.2 

With following version, there are no issues;
Unpdated WooCommerce Version Version 3.4.2
WooCommerce Multilingual Version 4.3 
WPML Media Version 2.2.3
WPML Multilingual CMS Version 3.9.4
WPML String Translation Version 2.7.3
WPML Translation Management Version 2.5.2 

With following version, there are no issues;
WooCommerce Version Version 3.4.2
WooCommerce Multilingual Version 4.3 
WPML Media Version 2.2.3
Updated WPML Multilingual CMS Version 4.0.2 
WPML String Translation Version 2.7.3
WPML Translation Management Version 2.5.2 

At the moment the dashboard requests me to;

"WPML Update is Incomplete
You are running updated sitepress-multilingual-cms, but the following component is not updated:

wpml-media-translation
wpml-string-translation
wpml-translation-management"

Is it safe to update to the latest versions of
wpml-media-translation
wpml-string-translation
wpml-translation-management?

June 15, 2018 at 1:06 pm #2415635

José Arcos

Hello again, I'm sorry for the delay on the answers.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.
You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

** IMPORTANT **

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:

hidden link
 

June 18, 2018 at 10:12 am #2418616

José Arcos

Hello again, sorry for this answer again, but I can see that with the latest version in the staging site the images are shown in both languages (see screenshot). Are you not seeing the same than me? Or is it a different issue?

Thanks.

June 18, 2018 at 11:47 am #2418954

arnoldS-2

I have updated to the latest versions and everything is still working. I think the order of updating each plugin and also their respective fixes helped solve this issue.

Thank you.