This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Bobby 4 months, 1 week ago.

Assigned support staff: Bobby.

Author Posts
June 10, 2019 at 9:39 pm #3990509

noamK-2

Hello,

Our website's main Language is English. Secondary is Hebrew - a right-to-left language.

We use Translation Editor for translating all our content, except when it is required to use string translation.

WordPress version and all plugins are up-to-date.

The issue we are encountering is as follows:

1. In one of our pages we use an image form our media library.
2. This image had a Title, Alt Text and Caption. They all appeared in translation editor and were translated to Hebrew successfully.
3. HOWEVER, Title, Alt Text and Caption are not the only meta fields that need to be translated.
When you go to Page Edit>>click the image>>click the pencil icon>>you get the Image Details window.
In this window, under Advanced Options you have the filed: Image Title Attribute.
We fill-in this field with the necessary title. However, this filed does not show in translation editor under the Media section (where the other 3 meta fields do appear), and therefore can't be translated.

June 11, 2019 at 4:11 pm #3997137

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

After some testing the default way to translate the Image Tittle Attribute is through the "text" editor of your WPML Translation Editor since it is added within a vc text box, you should be able to find the text box within WPML Translation Editor, click "text" and view the Image Title Attribute.

unfortunately xml wouldnt help her to add that field as it is a default WP field and not a page builder field or custom

June 11, 2019 at 5:17 pm #3997607

noamK-2

Hi Bobby,

Thank you very much for your reply.

1. Actually, your suggested solution is the first thing I tried before I approached your support yesterday.

2. HOWEVER, in translation editor, when I click the image in the text box and get the Image Details window with the Image Title Attribute field, I see the following problem:

Alt Text field, which I have already translated to Hebrew, displays in English.

See screenshots attached.

What do we do?

Thanks,

Noam Kroll

June 11, 2019 at 5:52 pm #3997877

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi Noam,

if possible i would like to take a closer look

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

NOTE : if access to the backend is not possible providing us with a duplicator package is just as good to review your locally without interfering with your live site

Thank you,
Bobby

June 11, 2019 at 6:41 pm #3998079

noamK-2

Hi Bobby,

Well. This would be a waste of time.

1. Actually, as a very seasoned user of WPML and of WPML support, this Image Details window in translation editor behavior, is not new to me.

2. See this ticket i opened 9 months ago, and answers I received from your 2nd tier support (after Amit Kvint had to intervene to speed them up):

https://wpml.org/forums/topic/insertedit-link-box-in-translation-editor-not-displaying-hebrew-search-results/

and you will understand what I mean. The 2 issues are connected and are actually similar.

Let me know your thoughts.

Thank you,

Noam Kroll

June 12, 2019 at 1:12 am #3998953

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi Noam,

i do not get the same results when testing locally.

for example :

1. Upload an image and add a default Caption, Alt text.
2. Add a new page -> add the image to the page-> now add the attribute
3. Click on "+" and add translation using WPML TE
4. Translate the caption and alt text
5. now go back to our original issue and click on the image to get the additional details and add the image title attribute

Reach 100% and review the results.

My results are as expected, the caption, alt text and the title image attribute translation which is the issue within this ticket , are all showing their translations in the front end.

Also for the backend , witihn the additional settings window of the image i get {%CAPTION%} and {%ALT_TEXT%} .

once you have saved in the front end what are your results ? do you now see the translated attribute , caption and alt text ?

June 12, 2019 at 10:32 am #4003117

noamK-2

Hi Bobby,

To better show you what I mean in my ticket, please see this screenshot video in which I explain the issue and also its link to the previous ticket I opened 9 months ago.

Here is a link to the video on my Google Drive:

hidden link

Let me know your thoughts.

Thanks,

Noam Kroll

June 12, 2019 at 7:23 pm #4007331

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

thank you for the screencast. I have read the previous ticket and second tier reports.

i understand that unfortunately at the moment this is the expected behavior within WPML Translation Editor

i dont believe the two are related but i was able to reproduce the issue and i am bringing it to the attention of our second tier.

once i have more news i will update you.

Also just to verify with you also

1. When you translate the image tittle attribute , and only the image tittle attribute leaving the alt text as is since it has been translated above within the Translation Editor , what are your results in the front end.

-> Does the translation show as expected ?
-> Is the original translation of the alt text overwritten and now it shows English ?

The topic ‘[Closed] Image Title Attribute field not in translation editor’ is closed to new replies.