This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Bruno Kos 5 months, 3 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
April 25, 2019 at 3:05 pm #3683731

Antony

Hi,

Unfortunately, when I now try to post links to my translated Japanese pages on Facebook, LinkedIn etc, the images and link preview are not available. The English pages are fine, and this is a recent issue, so I am wondering if this is related to the functioning/update of the WPML plugin? Here is an example page: hidden link

Thanks,

Tony

April 26, 2019 at 10:50 am #3689979

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi Tony,

Thank you for contacting WPML support!

When I open either hidden link or hidden link, I get a blank screen. Can you check this before we resume debugging this?

Regards,
Bruno Kos

April 26, 2019 at 11:27 am #3690277

Antony

Hi Bruno,

I have just updated to PHP 5.6 and can now see the pages (not sure if the two are connected). Are you able to view the pages? The English pages seem to be OK, so I guess it is related to WPML either way.

Many thanks,

Tony

April 26, 2019 at 2:25 pm #3691529

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

It it still not working - this is even incognito mode. Can you try with PHP 7.x.x versions? You can also try deactivating various plugins to see what causes this white screen (perhaps it is not happening if you are logged into the site).

You could also do this:

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Reproduce the issue.

3. Locate the debug log in: /wp-content/debug.log

This will all help you why does white screen appear.

Regards,
Bruno Kos

April 26, 2019 at 8:56 pm #3693281

Antony

Hi Bruno,

It looks like it might be the plugin W3 Total Cache. Is that a known issue? Are you also able to see the pages now?

Thanks,

Tony

April 27, 2019 at 8:36 am #3694961

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I can access the site now - I've shared the English page on my personal Facebook, but nothing gets picked up either?

However, you could always check this:
hidden link
hidden link

It is an Open Graph checker which shows which information is available to Facebook when sharing.

Regards,
Bruno Kos

April 29, 2019 at 9:08 am #3701439

Antony

Hi Bruno,

Thanks for your help. I seem to be able to access the pages and share on Facebook etc now. Could I confirm that you are able to, too, please?

Is WPML incompatible with the W3 Total Cache plugin?

Thanks,

Tony

April 29, 2019 at 11:50 am #3702925

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Could I confirm that you are able to, too, please?

Yes, I can see the page and it works.

Is WPML incompatible with the W3 Total Cache plugin?

It is compatible:
https://wpml.org/plugin/w3-total-cache/

It does have one issue at the moment, however:
https://wpml.org/errata/w3tc-is-not-minifying-files/

"W3-Total-Cache is not minifying files correctly for secondary languages when WPML setting default language in directory is active."

You can also see how to set everything properly:
https://wpml.org/documentation/plugins-compatibility/optimize-multilingual-website-performance-using-w3-total-cache/

Regards,
Bruno Kos

The topic ‘[Closed] Images and link preview not available for translated pages.’ is closed to new replies.