This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: 1. My settings are set up so that a user has to choose a product before theY can fill in the form, and then pay after they submit the form. The process still works correctly in Afrikaans, but in English it takes the user straight to the form, and it submits without checking out. I asked the theme author to double check my settings, he says the settings seem to be correct in both languages. Is it something I have to change in WPML settings? 2. The photos are not showing on the form when I edit the listing in English from the front-end (this also works fine in Afrikaans).

Solution: In order to make the packages appear in both languages, delete the translation of the add listing page and of the packages from your website. Once you did this, just simply create the translations back but with the Use WPML's Translation Editor option from the right sidebar set to Off. Deactivating the WPML editor for the listings, and translating them from the dashboard area made the images appear well in the translation too.

This topic contains 11 replies, has 2 voices.

Last updated by lorraineL-3 3 weeks, 2 days ago.

Assigned support staff: Radu.

Author Posts
September 13, 2019 at 11:43 am

lorraineL-3

I am trying to:
I am using the Listable theme by Pixelgrade. I initially built the website in Afrikaans, but now I'm busy translating everything to English using WPML. I've translated all the pages, listings, etc - I have the following issues:
1. My settings are set up so that a user has to choose a product before theY can fill in the form, and then pay after they submit the form. The process still works correctly in Afrikaans, but in English it takes the user straight to the form, and it submits without checking out. I asked the theme author to double check my settings, he says the settings seem to be correct in both languages. Is it something I have to change in WPML settings?
2. The photos are not showing on the form when I edit the listing in English from the front-end (this also works fine in Afrikaans).

Kind regards,
Lorraine

September 16, 2019 at 4:37 am #4576299

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Lorraine,

Thank you for reaching out the WPML support!

Let's take care of one question at a time. First of all, as far as I know, the flow for selecting a package is added by the Paid listings plugin. Could you activate a default theme (like Twenty Nineteen) and tell me if the issue is still available, please? This little change will show us if the issue is coming from Listable or from the plugin I just mentioned.

Thanks,
Radu

September 16, 2019 at 9:50 am #4578277

lorraineL-3

Hi Radu, thank you very much for responding. I installed the Twenty Nineteen theme, I'm still experiencing both problems though...

September 18, 2019 at 3:25 am #4592157

lorraineL-3

Hi, do you have any feedback for me on this?

September 18, 2019 at 9:46 am #4594469

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Lorraine,

Sorry for this delay but I had some issues accessing your website (I was getting 503 error message). Today I was able to have a look at the dashboard area and check this out but I still get this 503 error a lot of times (or the pages load very slow). You might want to reach out the hosting provider and ask for some help on this.

I tried to install the Paid Listings on my website and when I add a job package it appears on both add listing pages. Could you delete the translation of the add listing page and of the packages from your website, please? Once you did this, just simply create the translations back but with the Use WPML's Translation Editor option from the right sidebar set to Off.

This is what I did on my side and everything works very well. Please give this a try too and tell me how it goes for you.

Thanks,
Radu

September 18, 2019 at 2:19 pm #4597529

lorraineL-3

Hi Radu, thank you for your response. I did what you suggested and the issue regarding the products is sorterd out. I'm still struggling to figure out why the images are not showing up on the form when I edit the listing in English from the front-end. Could you see what the issue was with that?

September 19, 2019 at 8:22 am #4602519

lorraineL-3

Hi Radu, I deleted one of the translated listings and translated it the same way you suggested I translate the products. The album photos copied correctly. But I see now that most of the content doesn't translate - whether I'm translating with or without the WPML Translation Editor. These fields are populated using Myles Field Editor plugin - I tried looking for it on under WPML > Settings to double check if it's set to "copy / translate" but I don't see it. I checked, the plugin is compatible with WPML according to the author. Would you double check the settings? There may be something I'm missing?

September 20, 2019 at 10:01 am #4611207

lorraineL-3

Hi, do you have any feedback for me on this?

September 21, 2019 at 5:27 pm #4616585

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Lorraine,

I checked this out and I could see that this plugin is not a part of our WPML compatible plugins list (https://wpml.org/documentation/plugins-compatibility/) so there might still be some compatibility issues between these two. You can reach out the plugin author and ask him to apply for the Go Global program right here https://wpml.org/documentation/theme-compatibility/go-global-program/. This way, our compatibility team will work with the plugin author and make sure that everything is working very well.

I also checked the plugin a bit closer and I could see that the custom fields added by it are not set to be translatable. Let's take the tgcsa_gradering as an example (hidden link). You can go to Dashboard → WPML → Settings → Custom Term Meta Translation and search for this field. You can set to translate or copy. Can you try this out, please?

Thanks,
Radu

September 22, 2019 at 7:32 am #4617449

lorraineL-3

Hi Radu, thank you for your response, I will get in touch with the plugin author. Please see attached a printscreen of what it looks like when i search for the tgcsa_gradering field - am i doing something wrong?

September 23, 2019 at 7:24 pm #4626297

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Lorraine,

Please press the Show system fields button under Custom Fields Translation and search again for tgcsa_gradering. You should be able to find it this time.

Thanks,
Radu

September 25, 2019 at 7:54 am #4636517

lorraineL-3

Thank you for the help, that seemed to fix the problem. 🙂