This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 11 replies, has 2 voices.

Last updated by markB-8 3 weeks, 6 days ago.

Assigned support staff: Lauren.

Author Posts
September 19, 2019 at 4:42 pm

markB-8

Several images, built into our template and some directly referenced, are not translating as expected. We are hosting on WPEngine and have worked with them to remove some of the caching of cookies, but it's still not working.

As an example, the text-image in the header of our site (Healthcare & Hospitality) is not translating, as well as the header images on pages such as hidden link

The FR domain is hidden link

Btw, we believe we have correctly used the Media Translation module to enter the translated images. They just aren't showing up.

September 19, 2019 at 5:11 pm
September 19, 2019 at 6:33 pm #4607887

markB-8

Yes, we can see the images on the EN side and we have uploaded the respective FR image.

September 19, 2019 at 7:40 pm #4608183

markB-8

To clarify....that's in Media Translation. From what we can tell, and from your instructions, we have set it up correctly in Media Translation.

September 20, 2019 at 3:08 pm #4613239

markB-8

Hi Lauren, any update on this? I now have images that seemed to be correct yesterday reverting back. i.e. I was seeing the FR image on the FR site, and now they are back to being the EN images on the FR site.

September 20, 2019 at 4:25 pm #4613565

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I tried setting the header background image to translate instead of Don't Translate, but that did not seem to make any difference. I am thinking this may be a compatibility issue with the theme, since I don't see the theme listed here: https://wpml.org/documentation/theme-compatibility/

To test this, I have set up a fresh install. Please install your theme there and let's see if we can reproduce the issue. If so, I can escalate this to our compatibility team and they can reach out to the theme author.

You can access the test site here:
Login: hidden link
Username: demo
Password: G6vf5C7iKS8u

Please let me know once the theme has been activated and I will continue troubleshooting.

September 20, 2019 at 4:36 pm #4613599

markB-8

The theme has been installed.

I have used this theme before with wpml. That was before using the String Translation for images (image postids) and not the Media Translator.

September 20, 2019 at 4:49 pm #4613675

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Can you please expand on "That was before using the String Translation for images (image postids)"? Are you translating image IDs via String Translation?

September 20, 2019 at 4:55 pm #4613683

markB-8

That was how we were able to do image translation before, yes....like 1-2 years ago. However, now the images are not showing in String Translation so we are using Media Translation.

I still believe it has something to do with a cookie or something else being set and cached on WPEngine.

September 20, 2019 at 8:31 pm #4614355

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I don't think it is related to caching. I found that on the test site, the background image is stored in a field titled "the7_fancy_title_css". If you go to WPML -> Settings -> Custom Fields and click Show System Fields, you can find this field and set it to Translate. Then, when you edit the translation, you will see this field available for translation and you can replace the image url with the URL of the translated image. You can now see that the test site has two different images in the header for each language: hidden link

Please let me know if you need any further assistance and I will be happy to help.

September 21, 2019 at 1:20 am #4614573

markB-8

ok, i see that and the header images are working so far. But we've seen it working like this before and then after a day or so it switches back. Hopefully it'll stick this time.

But for the logos in the top bar, I still can't find them in the custom fields. I did find them in the 'admin screens' page. I check off the options and saved, but they still aren't showing up in the String Translation.

There's even a text field in the admin screens - Related News - which I checked off. But also I cannot find it in String Translations.

September 21, 2019 at 1:33 pm #4616093

markB-8

Hi Lauren, I believe my issue is now resolved. I found your support string here helpful:

https://wpml.org/forums/topic/cant-find-some-strings-to-translate/

Specifically, "Make sure that the WPML Translation Management add on plugin is activated on your site. Then, go to WPML -> Translation Management and click on the Custom XML configuration tab (screenshot attached). There, paste the following code:"

That's what I needed to do. Go to the admin screens and find the keys that were missing. Then add them to the Custom XML. And for this theme in particular, for the main logo, the image filename was not sufficient. I had to translate the image postid with the FR image postid.

I think we just have to note that Media Translation will not work with images that are included within the theme elements...at least this theme. It all still has to be done through String Translation.

September 21, 2019 at 1:34 pm #4616095

markB-8

My issue is resolved now. Thank you!