Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Itamar 4 years ago.

Assigned support staff: Itamar.

Author Posts
November 7, 2017 at 3:21 pm #1423388

francoisP-2

Hi,

Using WPML and WooCommerce I have a problem displaying images in the other language.

Main language is French and other is English.

French products are here: hidden link

In Media translation the following options were checked and the items were processed successfully:
- Translate existing media in all languages
- Duplicate existing media for translated content
- Duplicate the featured images for translated content

But the images for products in English are still not showing, see here: hidden link

What am I missing?

Thanks!

Regards,

François

November 8, 2017 at 6:45 pm #1425049

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi, François.

There two things that you can check regarding this issue.
A. If you are using any cache plugin or method on your server, try to clear the cache and see if it helps.
B. From the debug information, I can see that you have a low WP Memory Limit and this also might be the reason that when you check the options in Media Translation, they do not work.
By looking at the debug info, I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following minimal requirements:
- PHP 5.3 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above.
Please follow this link for a detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves strings issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code into that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add the code before this line:
/* That's all, stop editing! Happy blogging. */

Please understand that when using WordPress + WPML and its extensions + many other plugins it consumes a lot of memory from your server for your sites installation and this issue must be dealt with before anything else.

Could you please perform those procedures and see if it help?

Regards,
Itamar.

The topic ‘[Closed] Images do not display in other language’ is closed to new replies.