This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Andreas W. 1 year ago.

Assigned support staff: Andreas W..

Author Posts
May 8, 2019 at 6:25 pm #3770003


The main problem is that the images I change in the default language, don't change in other languages.

When I looked at he Plugins I noticed that the WMPL Media plugin wasn't activated anymore. When I wanted to activate the WPML Media plugin. I got a notification that it is activated, but it still is deactivated.

Can you help me solve this, because now it's twice as much work to change a image.

May 8, 2019 at 9:34 pm #3771291

Andreas W.

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)


Thank you for contacting the WPML Support.

Could you please try to deactiovate and delete the plugin. Then go to PLugins -> Add new -> Commercial and download and activate it again. If this will not solve the issue proceed with a fresh installation for WPML and all its add-ons. No worries, this will not affect any settings or translations as this data is saved inside of the database.

If this will not solve the issue please proceed as followed:
Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, enable the wp-debug feature to see if there are any current PHP errors given. Then provide the result of the debug.log file.
More information about how to activate this feature you can find here:

Kind regards

The topic ‘[Closed] Images don't change and wpml media plugin doesn't activate’ is closed to new replies.