If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 4 voices.

Last updated by Diego Pereira 9 months, 2 weeks ago.

Assigned support staff: Diego Pereira.

Author Posts
January 28, 2019 at 10:07 pm #3137609

joannaP

I am trying to:
Copy the images of the original post into translated pages.

I have select "Copy" (As well as "Copy once") under Multilingual content setup > custom field.

Link to a page where the issue can be seen:
Home page English: hidden link

Homepage Spanish: hidden link

I expected to see:
An image being copied over from the original post (English) into the translated page.

Instead, I got:

No Image. and when I check the value of css background-image it says 2. Like so `background-image: url(2);`

January 29, 2019 at 6:16 pm #3141235

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @joannap, welcome to the WPML support Forum!

Are you using the Advanced Custom Fields plugin to create the custom fields? If so, please make sure to have the ACF Multilingual extension enabled and to follow all steps escribed in this guide: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

If the issue persist, please check if the number 2 is the ID of the image. Perhaps the custom fields value is copied, but it returns the image ID instead of the URL.

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.
NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

All the best,
Diego

January 31, 2019 at 3:17 pm #3148529

joannaP

I have provided the debug. After checking the image ID, they are all 4 digits, so it couldn't be the image ID. What else could 3 be?

I also notice when I select other languages the value is 1 or 2. When is English the image shows.

January 31, 2019 at 6:56 pm #3149460

joannaP

In WMPL document mention that we should see the custom fields, but I don't see them.

January 31, 2019 at 10:37 pm #3149903

joannaP

I was able to bring the fields into the post and page, but the content still doesn't appear.

February 1, 2019 at 7:59 am #3150625

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+01:00)

hello Joanna, Konrad here, the author of ACFML

please, before you start translating the post with images in ACF fields:
- make sure that images which you want to appear in translated post are already duplicated/translated. You can do this in WPML > Media section
- while you are on original post edit screen, in the Multilingual Setup box (the one where you set "copy"/"copy once") click "show admin fields". when you see admin fields, find the field with the name similar to your image/gallery field (but the name will start with underscore _) and set this fields also as "copy/copy once/translate" (same as the field without underscore at the beginning)

February 1, 2019 at 8:14 pm #3153164

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

After following the steps that Konrad posted above, please let me know if the problem persists.

Thank you.

February 4, 2019 at 6:46 pm #3159205
joannaP

Hi,

What Konrad mentioned has solved the issue with AFC field, but as of now, we still can't translate contents that were built with SiteOrgine. How can we also get those contents translated?

Thank you.

New threads created by Diego Pereira and linked to this one are listed below:

https://wpml.org/forums/topic/split-translate-siteorigin-elements/

February 5, 2019 at 8:13 pm #3163591

joannaP

As of now, we are troubleshooting the following and we need assistant with:

Issue 1: Custom Field Translation [Global Setting] (Under WPML>settings)
When we try to select custom fields as "Copy Once" or "Translate" after saving the fields (with an underscore and without one) it would not save the fields or is not consistent with saving.

Issue 2: Custom Field Translation [Individual Setting] (Under Page > Multilingual Content Setup)
We also try to save these fields from each individual page, it still wouldn't get saved when click apply and it would roll back to previous selection.

We have updated our server php.ini to

max_input_var = 10000

since this was a previous issue, but that did not resolve the saving issue.

--

Request We also wonder if AFC fields could be recognized by there type in Global Setting (Under WPML>settings>Custom Fields Translation) as it shows on the individual page, please see screenshot for reference, this will allow us to identify which of the 1625 fields need to be translatable, otherwise we must go to all pages individually and select the fields (Which again is not saveable at this moment).

We appreciate if we can quickly get this resolved as quickly as possible, translators are waiting for contents to be sent.

Thank you

February 6, 2019 at 10:32 am #3165006

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

As the original issue is resolved may I kindly ask you please to open a new ticket for the additional questions?

We can handle only one issue per ticket. This will also help other users with similar problems to find solutions when searching the forum.

Kind regards,
Diego