This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 30 replies, has 3 voices.

Last updated by Alejandro 3 months ago.

Assigned support staff: Alejandro.

Author Posts
May 17, 2019 at 7:12 pm #3836633

markusB-49

I am trying to: See all media gallery images (product, projects, blogs) in all languages. This worked previously but since I upgraded the WPML plugin and use the media translator the media gallery images show in the original language version GERMAN only, but in all other languages the images have disappeared.

Link to a page where the issue can be seen:
Product overview with images: hidden link
Product overview without images: hidden link
Single product page with media gallery images (header): hidden link
Single product page with media gallery images (header): hidden link

I expected to see:
Images in the product overview per product and the image gallery (header) in the single product pages. I assume the product overview pulls the image from the media gallery.

Instead, I got:
No images are shown.

May 17, 2019 at 8:12 pm #3836825

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hi,
Welcome to WPML Support. I'll do my best to help you sort this issue out.

By "media translator", I suppose you mean WPML's feature to duplicate the images, correct?

If that's the case then you probably ran out of memory, because it could briefly use a lot of memory, if there are many images in the library.

So please add the following code to your wp-config.php file, right after the database information.
[php] define('WP_MEMORY_LIMIT', '200M'); <\code>

Then you can check if the configuration was successful if you goto WPML > Support, scroll to the bottom of the page and look for the "memory limit" label, which should now have a value of 200.

Then, please run the media translation procedure as before and see if that helps.

Let me know how it goes.

May 20, 2019 at 5:07 am #3843705

markusB-49

Hi Alejandro,
Thanks for the prompt reply.
I have performed the action as per your recommendation but the problem unfortunately persists although the memory issue seems to be sorted.
Kindly advise.
Thanks,
Cai

May 20, 2019 at 6:34 am #3843965

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Could you please allow me access to your site? And please could you also list me the steps you have tried so far so I can take a look and see what's going on?

Please add your WordPress credentials below, in the related fields, that way they will be private and secure.

May 21, 2019 at 8:06 am #3852895

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, i took a very good look at your site and now i have the following questions for you:

1) This post type doesn't have a featured image section as all other post types do, but i think it uses the first image of the gallery as a featured image, is that correct?

2) I believe the problem here is that your license doesn't have support for custom field translations and that might be why they are not getting "translated", but i do see that some featured images do get translated so there must be something i'm missing. can you give me more information on 1) so i can see if i have to look elsewhere for a fix?

3) For some reason all the products keep saying that you need to change language for them, which is not normal, but that shouldn't even be coming from WPML. I checked the pods plugin and this might actually be happening because of an old version of said plugin, the new version fixed several WPML bugs on their end, thus, updating it might fix at least some of the problems you're encountering.

4) Your Max execution time value is a bit low, please add the following code in your wp-config.php:

set_time_limit(100);

Please let me know, so i can continue debugging the issue.

May 24, 2019 at 5:06 am #3881147

markusB-49

Hi Alejandro,
1) Correct. Additionally, it looks like the faulty posts (product, project and blog) do not have the image gallery anymore, which is displayed in the original German post. That happened after the WPML was activated.
2) If you go into the media library you will note that all images are now available in all languages. The problem is that the original version GERMAN has the media gallery and all others don't anymore (see screenshots).
3) I noticed that, too. That too happened after installing the WPML plugin. I updated the PODS plugin as well as the WP version. The problem is still there.
4) Done.

Thank you so much for your help. I am trying to get behind this issue for weeks and it really messes with my website.

May 24, 2019 at 4:27 pm #3886263

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Since the problem is with a custom field, it's very likely the problem goes away with String Translation and Translation Management but that's not necessarily true, so i kindly ask you to please try to replicate the problem on this sandbox site:

hidden link

I think you can export the pods settings and import it in the sandbox, and then, please try to recreate the "products" page, do it with only WPML core enabled (as you did on your site) and let me know.

By the way, you don't have to create all the products in the sandbox site. 3-4 will probably work as well.

I'll then enable The other plugins and try to configure them to see if that fixes the issue.

Let me know when you do o if you have any questions or doubts about this process. I'll gladly do my best to make it cleared for you.

May 27, 2019 at 8:24 am #3894653

markusB-49

Did you change something on the site?
I am not sure what happened but it seems like it was even more messed up as products, news and projects have been doubled, no images at all, etc..
I have reinstalled a back up to where we left off, updated the WP version and plugins except the PODs plugin as I am not sure if that messes things up, again.
I believe this might be a problem between the WPML and Pods plugin?
Is there not a way to duplicate the German media gallery for all products, projects and news (blog) because that seems to be the issue after activating the WPML plugin - it simply removed the media galleries for all articles.
Pls advise.

May 27, 2019 at 8:47 am #3894771

markusB-49

This is the sample image.
It does not look like I can copy the PODs settings across. The pods plugin is the only one which has not been updated, yet.

May 27, 2019 at 9:29 am #3895313

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hi, The only things i did were:

- Added the Ajax Language cookie to the site, and i doubt that created the issue. i removed it afterwards to check and the problem was like that.

- I also ran 2 troubleshooting options (WPML > Support > Troubleshooting):
- Assigned the missing language code to the missing entries and then
- Sync'ed the taxonomies for all the "produkte" pages

WPML and pods are not officially compatible, but we have handled many sites with both plugins working well together.

hat's why i asked you to please try to replicate the issue as shown in this reply: https://wpml.org/forums/topic/images-from-media-gallery-not-showing-in-all-languages/#post-3886263

i kindly suggest you follow those instructions just to make sure we isolate the problem, because it could be the problem is due to Translation Management and/or String Translation Missing, but we need to make sure of it first.

Please let me knowwhen you do.

May 27, 2019 at 8:18 pm #3900759

markusB-49

Hi, no worries.
I am sure we will get to the bottom of this.
I don't really know how to best replicate the problem on the sandbox. Can you assist?
Also, pls see screenshot for POD warning.

May 28, 2019 at 4:58 pm #3908973

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ok, so i did some research (so i could give you more detailed instructions on how to do this)

1) Install your theme on the sandbox site
2) Configure WPML on the sandbox site using the same languages you're using on your site
3) follow this instruction to export your PODS configuration: hidden link

4) I'm not sure how, but if pods allow to export your settings, they will probably allow you to import them as well, so you'd have to import them on the sandbox site.

afterwards, you should have your "produkt" Custom post type created, and it's enough to create and translate a few dummy "produkte" and i think i can take it from there.

Let me know when you do

June 10, 2019 at 7:22 pm #3989849

markusB-49

Sorry, the replication took some time. The site is now completely replicated onto the sandbox and I used the four three images for the products "Absorber A100".

I noticed that he custom fields in all other languages than German are not there anymore.

Can you take it from here?

June 11, 2019 at 4:07 pm #3997131

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

May i know where did you upload the entire installation? the sandbox site is expired which means it wasn't accessed in more than 7 days. so i'm afraid we ahve to start over:

hidden link

If you can, you can upload everything in that site and let me know the steps i need to follow to encounter the issue in his sandbox, because in the end, i need to replicate the problem in order to troubleshoot it.

Let me know.

June 18, 2019 at 6:52 pm #4046039

markusB-49

Hi there,
I have replicated the page again.
I uploaded the first three images for the products "Absorber A100".
hidden link
You can see them the German version but not in the ENG as the media gallery does not show any images.
Can you take it from here?

The topic ‘[Closed] Images from media gallery not showing in all languages’ is closed to new replies.