This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Diego Pereira 1 year ago.

Assigned support staff: Diego Pereira.

Author Posts
September 25, 2018 at 1:47 pm

francoB-8

Hello, Some month ago I already open a ticket for the same problem, but after some tries, no solution works. If I go to Media Translation I can see all of the images loaded in ACF, but it tells me to "use a different image" and I want to duplicate all the images in English, because are images without texts.

hidden link usr: demo psw: clienti2018

In italian all of the images works, in english, only text of the ACF are translated.

September 26, 2018 at 6:26 pm #2768414

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @francob-8, welcome to the WPML support Forum!

Please try the following:
- Go to WPML > Settings > Post Types Translation and check if the Media (attachment) post type is set to Translatable (only show translated items). If not, please set this option and save.
- Scroll down to Media Translation, run the scan and and check the fields according to your preferences. Save.
- Go to the edit screen of the page (default language)
- Scroll down to Multilingual content setup
- Set all image fields to "Copy" and click on Apply
- Do a small modification on the page and save
- Edit the translation and save.

Please let me know if it worked for you. If not, please send us the link of the previous ticket, we will take a look.

I also checked the settings of your server through debug log and saw that some items need attention:
Increase WP memory
Please increase the PHP memory limit to 256mb. Currently this memory is set to 40mb only.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

All the best,
Diego

October 2, 2018 at 4:50 pm #2782311

francoB-8

Hi Diego, I already done everything you told, but images of the ACF Pro are still visible for Italian only, not english. I refer this for Home page. Can you enter in admin and see if there is something else wrong? Images in italian are correct, in English always show the "img broken" icon. Thanks in advance

October 3, 2018 at 1:08 pm #2784633

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Sure, I can take a look. I tried the credentials of the first post but it's not working (ERROR: Incorrect username or password). Could you please check?

Regards,
Diego

October 3, 2018 at 1:16 pm #2784644

francoB-8

Hi Diego, credentials for seeing the website are:
[content removed]

October 3, 2018 at 8:00 pm #2785660

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks. The credentials worked. It's odd because the fields are not displaying on the Multilingual COntent Setup section as they should.

I'll need to replicate your site locally to run some tests. For this please install a plugin called “Duplicator” and "Migrate Guru" on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please let me know if this is ok for you.

Regards,
Diego

October 4, 2018 at 7:30 am #2786558

francoB-8

Hi there,
I already installed and activated both plugins.

October 4, 2018 at 6:38 pm #2788574

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks. I duplicated the website and noticed that the fields are not being displayed on the Multilingual Content Setup because the WPML Translation Manager is disabled.

Please try the following:
- Activate WPML Translation Management
- Go to WPML > Settings > Post Type Translation and set the field-groups post type to "non-translatable"
- Go to the edit screen of the page (default language)
- Scroll down to Multilingual Content Setup
- It should display the list of the fields. Set all fields related to the images (e.g. "aiuto_repeater_2_immagine_loop") as "copy-once"
- Click on Apply
- Scroll up, upload the images again, do a small modification on the text content and click on Update
- Go to the translation editor, check all "Translation is complete" fields (translation 100% complete) and save

If it does not work, please try to upload the images directly on the translation using the manual editor:
- Go to the edit screen of the page (default language)
- Change the language using the Language Switcher at the top admin bar
- If it display a warning, click on "Edit Anyway"
- re-upload the images to the translation and save

Please let me know if it worked for you.

Regards,
Diego

October 8, 2018 at 3:39 pm #2796772

francoB-8

My issue is resolved now. Thank you!

October 8, 2018 at 4:02 pm #2796827

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there, I'm glad to hear that the issue is solved ?

Please contact us if you need our help in the future with WPML. We will be more than happy to help.

Cheers,
Diego