Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Mateus Getulio 4 months ago.

Assigned support staff: Mateus Getulio.

Author Posts
April 11, 2022 at 5:34 pm #10997327

istvanM

Hi,

This ticket is a follow-up of the previous one: https://wpml.org/forums/topic/images-in-elementor-galleries-are-not-showing-up-in-translation-editor/

While recently the problem was that Elementor Gallery images were not appearing in the translation editor, now the problem is that there are more images appeared in the Translation editor than the number of images in the original post.

We are translating posts to English from our Hungarian blog hidden link

We experienced this issue when translating this blog post: hidden link

In the attached screenshot there are examples: those images with "Title" field are not part of the original post.

Screen Shot 2022-04-11 at 19.30.16.png
April 12, 2022 at 8:08 pm #11006961

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Thanks for your contact, and welcome to the WPML support forum!

Let's try some possible solutions for this issue. First, as a quick test, could you please try to remove the WPML plugins and reinstall them?

If the problem persists after this procedure, please test this:

- Go to your affected post, and do a minor modification to the original language
- Try to translate it again and see if the additional images will disappear

Another attempt that you can try is to duplicate the post using the Yoast Duplicate Post plugin and check if the issue will be reproducible in the dupe post.

If nothing of this works, then we might be facing an interaction issue with a third-party functionality, in this case:

- Deactivate all the plugins that are not related to WPML
- Switch for a moment to a WordPress default theme like Twenty Twenty-one
- If the issue is gone, activate one by one to see with which one there is an interaction issue

Just make sure to have a complete website backup before doing it. Please give it a try and let us know about your results. Thanks!

Kind regards,
Mateus.

April 13, 2022 at 9:13 am #11010663

istvanM

Hi Mateus,
Thank you for your answer. In the meantime I checked those extra images that appeared in the Translation editors. I found that those images were uploaded to Media Library as images belonging to the original post (see attached screenshots)
(Uploaded to) Feltöltési hely: Nyugaton a színek is mások – A hanyatló kapitalizmus színes fényképeken
Later some of these images were not used in the final version of the post. I suppose that is the reason why Translation editor considers these images as part of the original post and offers for translation.
Can you confirm this?
1. Is it true that the Translation editor checks Media library and selects all those media files which were uploaded to the original post?
2. Is it true that Translation editor does not check whether an image, which was uploaded to the original post still exists in the final version of the original post?

Thanks for your help

Screen Shot 2022-04-13 at 11.02.08.png
Screen Shot 2022-04-13 at 11.02.36.png
April 13, 2022 at 8:41 pm #11016611

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks for your reply.

Could you please tell me how exactly did you previously insert these images on the post? Moreover, if they were deleted, they shouldn't be appearing on the Translation Editor.

Please try to perform the steps that I mentioned before, and check if they'll be helpful. If you're still stuck, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

April 14, 2022 at 8:32 pm #11024311

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thank you for providing the website credentials.

Upon further inspection, we could conclude that this behavior is expected and not related much to WPML. It is normal that attached images to post are listed. If you create a post, open the media gallery from there, and upload an image, it is automatically attached to that post.

All of those are considered in CTE when translating and shown – as they have a child-parent relationship with the post. The only way to un-attach is to delete it from the media library or to use “Unattach” button there next to the image (I'll show it to you, in case you don't know where to find this button).

If you disable WPML plugins, you will see images are still attached to that post, so when using WPML it is normal they are showing in the Translation Editor.

We test the 'unattach' procedure for two images, and they don't display anymore on the Classic Translation Editor (fortepan_188418 and fortepan_194148). We followed these steps:

- Click on Media from the WordPress Admin menu
- Switch the view to Media List: hidden link
- Find one of the media you would like to detach from the post
- Verify under the “Uploaded to” column that the media is attached to the post
- Directly below the name of the post or page it should say “Detach”. Click on “Detach”
- Now go to the original language post and make a small edit (like an extra space)
- Open the Translation Editor and check that the image is not there anymore

It should be solved with these steps. Please give it a try and let us know if they work for you. Thanks!

Regards,
Mateus.