Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by jonasP-13 1 month, 2 weeks ago.

Assigned support staff: Radu.

Author Posts
April 18, 2021 at 4:34 pm #8565625

jonasP-13

I am using Elementor on my website to build up my pages. My "standard" language is set to german. On one page, I also inserted one image which should be shown on all translations of that page.
For each language, I went through the Advanced Translation Editor. At the end of the list, there is also the entry which is used for media translation (Screenshot1). I set this to the value of the "german" translation. Nevertheless, the image does not show up on the translated page (Screenshot2 = german page, Screenshot3 = english page).

In the developer console of my browser, I saw that the image is inserted also on the english page, however, its dimensions are wrong (Screenshot4 = german page, Screenshot5 ) english page).

Can you help?

Screenshot5.PNG
Screenshot4.PNG
Screenshot3.PNG
Screenshot2.PNG
Screenshot1.PNG
April 20, 2021 at 6:08 am #8577419

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Jonas,

I tried to have a look at your website, so I can check the images, but it seems that it's in maintenance mode.

Now, can you make sure that the Duplicate uploaded media to translations and Duplicate featured image to translations options are checked on the right sidebar, on the section where you can edit the translation, please?

Also, please go to WPML → Settings → Media Translation and press the Start button, please? Once the process is done, please have another look at the translated page and tell me if the image is still missing.

Thanks,
Radu

April 20, 2021 at 7:19 pm #8584969

jonasP-13

Hello Radu,

Thanks for your reply. Currently, the website is in maintenance mode, however, I would like to give you access to WordPress so that you could have a look at the problem. Can you please tell me how to share the credentials with you (when creating a new ticket, I have seen a section which made this possible, however, when answering this ticket I cannot see such a section for providing credentials).

I already made the procedure with the "Start" button in WPML -> Settings -> Media Translation and this corrupted the whole image library (which is why I would like to avoid clicking on the "Start" button again). I deleted all images and the media library and uploaded them again after checking that the settings in WPML -> Settings -> Media Translation are correct (all checkboxes were selected for media which will be uploaded). As far as I understood the procedure with the "Start" button is only necessary for media which were already there before installing WPML.

Thanks for your help.
Kind regards
Jonas

April 21, 2021 at 12:34 pm #8590637

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Jonas,

I set the next reply to be private so you can safely send me the credentials for the dashboard area. Also, please attach a link to the page where the image is used too, so I can make sure that I'm checking the right element.

Thanks,
Radu

April 26, 2021 at 9:27 am #8622189

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Jonas,

Can you check the English page now, please? The image is showing well now.

What I did was to disable and enable back the Jupiter X theme Cache Busting option. Maybe this cleared some caches and made the right size be applied to the image on the translated page.

Thanks,
Radu

April 27, 2021 at 7:54 am #8631319

jonasP-13

Hello Radu,

Thanks again for your reply! My issue is resolved now and I can see the image also on the translated page.

Thanks for your help!

Kind regards
Jonas