This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 3.42 hours from now. Thank you for your understanding.

This topic contains 6 replies, has 2 voices.

Last updated by Itamar 2 months ago.

Assigned support staff: Itamar.

Author Posts
August 6, 2019 at 2:53 pm #4348883

alexanderW-44

I am trying to: translate image titles on a variety of pages.

Link to a page where the issue can be seen: hidden link

I expected to see: all my updated images.

Instead, I see old images are visible and some of the newer updated images are missing.

August 6, 2019 at 5:47 pm #4349809

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Please confirm that you are following out instructions on how to use WPML media?
https://wpml.org/documentation/getting-started-guide/media-translation/

Are you trying to have different images for each language?
Can you please tell me which title you are trying to translate?
Please attach some screenshots so I can better understand.

Thanks,
Itamar.

August 8, 2019 at 9:02 am #4361317

alexanderW-44

Hi Itamar

I have followed the documentation but still haven't come right. I am using the media translation plugin however I am not trying to use different images. The reason I am doing it this way is becasue I cannot revert to the wordpress builder to translate the images otherwise all my content will be lost using the Divi builder.

I have attached a screenshot of the homepage image translations, as you can see, many images are missing and even some old ones are showing.

I hope you can assist with a solution 🙂

August 8, 2019 at 8:50 pm #4365981

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the extra details.

By looking at the screenshot, it is hard for me to know which images are old and which are not. I think that I'll get the issue better if I'll check it on your site. Please explain to me where to go to see the issue. Please also mention in what Divi modules you are adding those images.

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

August 14, 2019 at 7:59 pm #4397285

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details.

I've checked things on your site, but I'm sorry I still can't understand what the problem with the images on the homepage of your site is. When I check the front-end of the homepage in the different languages of the site, all the images look the same.

I understand that the homepage is built with Divi.
In which elements of the page, the problem exists?
Please elaborate and add some screenshots.

Note: I'll be able to reply on Sunday.

Thank you for your patience.
Itamar.

August 16, 2019 at 3:09 pm #4407217

alexanderW-44

HI Itamar

All the images circled in the last image are missing form the translations page. I need to rename all these images in each different language.

I mentioned using Divi becasue your documentation suggests using the standard WordPress editor to change the image names however Divi does not allow you to revert to the standard editor becasue you will lose all you data. This is why I am using the image plugin to change the names.

I hope this helps.

August 18, 2019 at 6:51 pm #4412619

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

You wrote: "I mentioned using Divi becasue your documentation suggests using the standard WordPress editor to change the image names..."
Can you please send me the link to that documentation so I can understand better?
Also can you please tell me in which Divi modal the old images that appearing for translation used to be?

You wrote: "I need to rename all these images in each different language."
To do this please go to WPML -> Media Translation and translate the name and the alt text from there. Please see the attached screenshot media-name-alt-text.jpg. Please note that you might need to remove and then add again the image after that you have changed it, in order for the translation to show. You would need to update the original page and then the translation.
Please let me know if this information is helpful to you.

Regards,
Itamar.

The topic ‘[Closed] Images not shoing in translation’ is closed to new replies.