This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 10 replies, has 2 voices.

Last updated by Bruno Kos 4 months, 4 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
May 15, 2019 at 10:56 am #3815215

jamilA-5

I am trying to understand how to make the images appear again

Link to a page where the issue can be seen: all the pages (eg. hidden link )

I expected to see: images on the left side of the page (we are using the Image Widget Plugin)

Instead, I got: images on the left side are disappeared

We need to solve this problem as soon as possible

May 15, 2019 at 12:17 pm #3816327

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you tell me the following:
- is this original page or a translation (based on the URL, it is mostly likely an original)?
- I don't see language switchers here - does this page have a translation and is image widget showing there?
- is the image widget available if you deactivate WPML and its addons?

Regards,
Bruno Kos

May 15, 2019 at 1:31 pm #3817043

jamilA-5

Hi and thanks for answering me,

I tried now to deactivate the main WPML plugin and all the WPML-related plugin and now the images are reappeared again so I think there should be like a conflict between them. How can we solve the problem?

Regarding the pages yes, the link I provided you is in the original language and we didn't put any language switcher just because we don't need it for now.

May 15, 2019 at 1:36 pm #3817079

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

It may be that this widget is set to show on another language (not the language in which this page is created), or that the content of the widget is not translated into other languages, so it is hidden by default.

Can you try this:
https://wpml.org/documentation/getting-started-guide/translating-widgets/displaying-different-widgets-for-different-languages/

Perhaps you could also try duplicating the widget and setting each instance to show on another language. Does it help?

Regards,
Bruno Kos

May 15, 2019 at 1:46 pm #3817237

jamilA-5

The widgets are already set to be seen in all languages so this is not our case. Regarding the translation of the contents the problem is that we don't have any content, they are just images and I checked on the Media Translation and they are already translated in english because english is the main language of the website.

Any other solutions?

May 15, 2019 at 1:47 pm #3817241

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

In order to debug this issue further quickly, would you be willing to provide me with temporary WordPress admin username so I could investigate the issue directly? I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

May 16, 2019 at 12:58 pm #3826081

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I've checked inside and tried few things, but to no avail. What I think that the reason could be any of the following:
- AH Display Widgets compatibility issue
- Image Widget compatibility issue
- combination of two

From what I see, AH is being used to display these widget based on conditionals. Therefore, can you check my next message?

Regards,
Bruno Kos

May 16, 2019 at 1:24 pm #3826265

jamilA-5

I tried all the different combinations but in the sandbox you created everything working fine. I don't think the problem is this. Any other solutions?

May 16, 2019 at 2:13 pm #3826809

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can I ask you the following then? In order to debug this issue, can you install Duplicator plugin and create package so that I can try this on my localhost and possibly escalate further to Compatibility team?

https://wpml.org/faq/provide-supporters-copy-site/

Let me know if this is OK with you.

Regards,
Bruno Kos

May 17, 2019 at 7:48 am #3831903

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

It is actually not working, even on our Sandbox site.

Steps to reproduce:
- Add any widget to sidebar
- Select option "Show on checked pages" and choose some page
- The widget will still not show
- However, the reverse option ("Hide on checked pages") works properly and hides a widget on a given page

So based on my testing, it is about "Show on checked pages" option which does not work properly.

This has been escalated to our Compatibility team and may take some debugging time, I'll get back to you as soon as I have any news or questions for you.

Regards,
Bruno Kos

May 22, 2019 at 5:34 am #3861007

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I got a response from our second tier and is the same as this:
https://wpml.org/forums/topic/error-sidebar/page/2/#post-3841893

AH Display widget is actually a fork or another plugin (Display Widges) and there is a problem with is how the conditions of the options are implemented. It has been reported here a while ago and most likely will not be resolved, therefore we suggest to use Widget Logic plugin instead.

Regards,
Bruno Kos