This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Yvette 1 year, 1 month ago.

Assigned support staff: Yvette.

Author Posts
September 14, 2018 at 8:08 pm #2736617

hichamb-3

I am trying to: see my images gallery within french and english pages..

Link to a page where the issue can be seen:
hidden link
I expected to see:
hidden link
Instead, I got:
2 images instead of 150..

I look around the wpml forum posts to search for solutions. In my case, first, i have imported 500 images in my media library. I used its within my posts. All was good, my images galleries displayed for each languages. but my client asked me to modify some images titles for the others languages.. So , i installed the wpml media plugin. And from this moment, i could not see my images galleries within others languages. How can i resolve this ? Do i need to delete all my library images and import my images again and do the all process again ? first with my default langage and then the others languages ?
Other problem, when i want to import new images, i have a memory issue like :
Fatal error: Out of memory (allocated 132382720) (tried to allocate 88 bytes) etc...
when i deactivate WPML plugins , the image importation works.. I contact my host website support, they confirmed my php memory was 256M.
Last point... my backoffice is very slow, i have some "connection lost" sometimes when i refresh or publish pages..

Thanks for your help !

September 17, 2018 at 9:16 am #2740349

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

1.Media Duplication
Can you verify if you have executed the full Media duplication steps here:
- goto WPML -> Settings -> Media Translation -> select all options and press the "Start" button.

2. You wrote: "..my client asked me to modify some images titles for the others languages..."
How did you execute these title changes? Did you use WPML -> Media Translation? or did you execute the change via the Media Library?

3. Memory Issue
Please confirm that you have the following line in you wp-config.php file. If you do NOT see it, then please add it :

define('WP_MEMORY_LIMIT', '256M');

After doing this, please see if you still get the same memory error.

4. Technical Information on you environment
Could you please provide information about your environment by following thsese steps: http://wpml.org/faq/provide-debug-information-faster-support/

Thanks

September 17, 2018 at 3:09 pm #2741610

hichamb-3

Thanks for your response Yvette !
1- I haven't execute the full media duplication. Now, all is working fine !
3- yes i confirm. But issue memory still persist 🙁
"Fatal error: Out of memory (allocated 136314880) (tried to allocate 88 bytes) in ...fiestaclasica.org/wp-includes/wp-db.php on line 1889"
4- I can't duplicate my website. i have an error during exportation with duplicator but i have a zip of my whole website... could it help ?

September 17, 2018 at 8:20 pm #2742486

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

1. I understand that the images issue is now resolved and the only remaining issue is the memory allocation issue. Correct?

2. You do not have to provide a DUPLICATOR...just cut and past the contents of the box in this navigation path into the form in your reply:

WPML -> Support ->Debug Information (see image)

September 17, 2018 at 8:27 pm #2742513

hichamb-3

1 - Yes ! thanks you!
2- Here is the debug report

thanks for your help !

September 17, 2018 at 8:43 pm #2742569

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hmm -the debug information says you have much more than 256M available for you to use. If you increase the quantity limit to 512M - what happens?

i.e change the line in your wp-config.php to this:

define('WP_MEMORY_LIMIT', '512M');

September 18, 2018 at 1:06 am #2742856

hichamb-3

i contact my web server hosting. They told me that the max memory was 256M. When i contact you for the first time, my wp memory limit was 512M.. and i had same memory issue.. , i tried with 1024M.. same issue...
I made a test by deactivating "WPML String Translation" plugin. And images upload works !! I don't know what happened with this plugin 🙁

September 18, 2018 at 8:17 am #2743991

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Yes, increasing the WP_MEMORY_LIMIT' value will make no difference if it is greater than the amount that your hosting subscription has allocated.

e.g. if you increase the value of WP_MEMORY_LIMIT' to 1024M but you only have 256M available on your hosting subscription, then the increase has no effect.

Apart from telling you that you need more memory, there is not much else I can advise. This is really a server issue.

The WPML suite alone requires 128M to operate. Other plugins like Woocommerce also require 128M. The combination of what plugins you have installed and how your theme is written can eat up memory very quickly. Not to mention the size of your database...

If you are convinced that it is an issue with WPML Plugin, here is one way to confirm this:
1. Temporarily deactivate ALL your non-WPML plugins
2. Change your active theme temporarily to Twenty Seventeen
3. With this setup, do you still have trouble importing an image?

Thanks for trying this. If it is still not possible, I would ask that you please create a Duplicator snapshot with this configuration. If you . have problems doing this, I can do it for you if you provide access to your site. I am opening the private area for this information.

PS. Deactivatig and tepoarily changing your theme SHOULD NOT change any theme settings but, just in case, you should make a backup of your db. Better safe than sorry.

The topic ‘[Closed] Images only displayed within default language pages’ is closed to new replies.