If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 28 replies, has 5 voices.

Last updated by Alejandro 7 months, 2 weeks ago.

Assigned support staff: Alejandro.

Author Posts
March 16, 2019 at 7:16 am #3359087

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

If it's a compatibility issue, we'll need to reproduce the issue on a fresh install in any case.

If you want someone else to take care of this thread I'll reassign it, but since we have limited support over the weekend you probably won't receive a reply before Monday.

March 21, 2019 at 3:02 am #3394885

williamS-2

Yes a new agent would be best, I would like someone who will make a copy of my site, as another agent did for a different issue, and fix it at long last.

March 21, 2019 at 8:53 pm #3422779

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Hi there, I'll be taking over this ticket from now on. I had deleted the copy of your site from a previous ticket, but I downloaded the Duplicator files and am setting up a new copy now so that I can further test. In the meantime, let's try a few things.

Please go to WPML -> Settings and in the custom field section, click "Show hidden fields'. Then search for gallery. I saw two results in my screenshot. Please set both of these to Copy and click Save.

After these steps, do the images get reordered correctly? If you aren't able to test this, I can try it once my test site is up, I just figured this might save us some time.

The reason we aren't contacting the author directly because we ruled out compatibility. Just as Laura had you do, when we tested the theme on a fresh install, the images copied and reorded without a problem, which indicates it is not a direct issue with the theme/plugin. That's why I'm thinking there must be a setting or something somewhere that needs to be changed, but I couldn't find a field related to ordering the gallery.

So, let's see what setting those gallery fields to copy does. I have attached a screenshot for further reference.

March 24, 2019 at 10:39 am #3448101

williamS-2

Didn't work.
Check out /th/property/1bed-condo-aspire-rama9/
Try to delete or reorder images, just doesn't work.

Delete one and it comes back on pressing update, and in the out of sync order.
Some posts are showing the correct order, but they were before anyway.

/th/property/lpn-rama-9/ tries to show deleted images, can't delete the deleted images, can't reorder.

I have tried completely deleting the post and original translation, clearing caches, then making the post from scratch in both languages, same result, can't delete or reorder images.

March 25, 2019 at 9:30 pm #3458255

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thanks so much for testing this for me. I've now got a copy of your site set up locally so that I can run further testing. I will update as soon as I have more information. THanks for your continued patience.

March 26, 2019 at 2:52 pm #3463775

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I have escalated this to our 2nd Tier Support team. I will be working with the developers to find a resolution and will keep you updated here. Thanks for your patience while we continue to troubleshoot.

March 27, 2019 at 2:12 am #3467265

williamS-2

OK, thank you.

March 27, 2019 at 1:22 pm #3471377

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

You are welcome, I hope to have an update for you soon.

March 29, 2019 at 6:18 pm #3493859

williamS-2

Any light on the horizon?

April 1, 2019 at 1:53 pm #3508579

williamS-2

Anything?

April 1, 2019 at 6:47 pm #3510979

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

First of all, my sincere apologies for the delay. According to the 2nd tier support, this has never been possible.

However, there is a simple work-around.

Go to WPML > Media Translation and replace the images with the images that you want - in the specific order.

e.g. if your first image is a house and you want to have a cat instead in the translation - translate the image of the house with a cat and save.

There is no other way as far as I know, except to not translate the images at all - disable copy of the images in the translation in WPML > Settings > Media - all settings off, and then upload images specially for the second language.
This can be done only in native interface and not in TE/ATE

Please, could you check if the above workaround mentioned by 2nd tier support works correctly?

Thank you.

April 2, 2019 at 3:40 am #3513439

williamS-2

OK I'm very confused now.
I had WPML on sites before and it copied the images in the same order, even on some posts on this site it copies them in the same order.
Not sure how that is a thing that was not possible, I've seen a lot of posts re this in the support forum.

However as stated before, when it misbehaves I can't even delete an image to try your work around.
If I delete an image, click update, it's back again!
I can unclick duplicate uploaded media and delete every single image on a translation, click update, and they're all back!

I did explain this clearly, not sure how they missed that.

What is te/ate?

I'm trying to be patient but this thread has been running for a month now and still no resolution in sight, now it seems the tech guys aren't even reading the information re the problem.
Now they are saying that WPML doesn't copy images in order, which is clearly untrue, it did on previous sites.

April 3, 2019 at 10:37 am #3524637

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello, my name is Alejandro.

Since Lauren currently has a few days off, I will replace her here in the forum.
I hope this is OK with you.

This is actually not a bug but more of a glitch, and it's happening because you are trying to update the translation page gallery instead of updating the original page's which by the settings (set by the theme author) shouldn't be done.

The theme author set the gallery images configuration in a way where the users would have the gallery settings (quantity of images, order, etc) "cloned" for all translations.

To "fix" the problem you're facing, you have to go to the original language property and edit it (add a character in the title or add something that triggers a WordPress revision), click the update button and then update your translation, you'll see that the images will fix themselves then.

I already did this for this page: hidden link

Try it out and let me know how it goes.

April 3, 2019 at 10:47 am #3524727

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Oh by the way, if you just want to rearrange the images on the translated languages, you can just go to WPML > Settings > Post types > find "REAL_HOMES_property_images" > Set it to "copy once.

Then click the save button on that section and rearrange it and then revert the process (change REAL_HOMES_property_images to "copy" again)

I think this happened because the image wasn't already duplicated in the other language so it messed with the order.