This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 44 replies, has 3 voices.

Last updated by mennoB-4 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
August 5, 2019 at 1:23 pm #4340899

mennoB-4

Link to a page where the issue can be seen:

hidden link

I expected to see:

In this page the image 356X226-copy.gif have a link to the page :
"hidden link"

code:
<img src="hidden link" width="356" height="226" alt="">

Instead, I got:

an empty gallery light box....

link: hidden link

I need to link the img. to the english page. of:
hidden link

August 5, 2019 at 6:52 pm #4342623

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us:
http://wpml.org/faq/provide-debug-information-faster-support/

In case you are using a page builder different than Elementor it might be possible to solve the issue by adding a custom XML config for the page builder shortcode element to the WPML settings.

https://wpml.org/documentation/support/language-configuration-files/

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

August 6, 2019 at 7:12 am #4344669

mennoB-4

Is there a way to edit the translation code manually in WPML?
thanks

August 6, 2019 at 7:44 am #4344731

mennoB-4

Also, I would like to comment that in the lower button I get the same problem as in the upper image link.

At the bottom of this page:
( link: hidden link )

...there is a "btn" with the text "go to the jobs page".

This link should link to the "english page" but link to the "NL" page

( hidden link

_____

Is there a way to edit the translation code manually in WPML?
thanks!

August 6, 2019 at 9:49 pm #4350557

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The most simple solution here would be to go to the page editor, change the admin language inside of the top admin bar, and edit the page builder options for the Media Gallary single Block of the job.

I have now here manually edited the correct URL for the job opening.

Another alternative might to switch to the Classic Translation Editor, as it seems to me the issue might be related to the Advanced Translation Editor.

I would kindly like to ask you to install the Uncode Theme, including your child theme and the plugins Uncide Core and the Uncode WP Bakery Page Builder on the following test site in order to see if the issue persist on a new installation of WordPress:

One Click Login: hidden link

Also please try to disable additional plugins when translating further elements of this media section and let me know if the issue persists. It might be that another plugin is causing the Advanced Translation Editor to not translate the custom URL properly.

Leave me a short notification once the test site is ready.

Kind regards
Andreas

August 7, 2019 at 7:05 am #4352397

mennoB-4

Hi Andrea,

sorry, I don't have time to install files
I can send the files to you privately.

Thank you for the advice but unfortunately I don't have time to try different options.
I need a solid solution.

I need a definitive bilingual solution for my site. If WPML plugin does not work correctly and I waste a lot of time I need to find an alternative solution.

Thanks,
Best Regards

August 7, 2019 at 9:46 pm #4358425

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

Please take note that in order to determine if we are handling with a compatibiltiy issue between Uncode and WPML it is mandatory to be able to recreate the issue on a new installation of WordPress.

I would kindly like to ask you to visit the test site:

One Click Login: hidden link

I have installed Uncode at its latest version and created two pages, including the Uncode WPBakery Media Gallery. Sadly, I am not as familiar with the theme and page builder. I have tried to recrate the issue but I am not able to complete the task.

I would kindly like to ask you for assistance in order to recreate the issue or please provide detailed steps:

- How did you designed the Media Gallery item?

- How did you achieved to make the custom link open on a new page? By default the image custom link opens as a popup.

- Please, clarify if you used an custom code to create the page section?

Also make sure to update zour theme and see if the issue persists. Your currently used theme is outdated.

Kind regards
Andreas

August 8, 2019 at 12:02 pm #4362447

mennoB-4

Thanks for your reply Andreas,

- You need to change the setup insi de "module" tab : "lightbox to link" to ad a url
- And then ad the url in the single block
( screenshots attached )

hidden link

_______________

I created a new page and I got the same problem:

hidden link
(database engineer box)

link
hidden link

thanks

August 8, 2019 at 3:44 pm #4364339

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Please take a look at the shortcode generated by the Uncode WPBakery PageBuilder.

This code does not provide any URL which for the link will not be translatable with the WPML Translation Editor. For now those links will need to be edited manually to each page in respect to their language. As you can see on mz test site the translation is succesful if translated manually using the WordPress page editor.

<p>[vc_row][vc_column width="1/1"][vc_gallery el_id="gallery-111792" medias="37" gutter_size="3" media_items="media|custom_link|original,icon" screen_lg="1000" screen_md="600" screen_sm="480" single_overlay_opacity="50" single_padding="2" title="Job Board" items="eyIzN19pIjp7InNpbmdsZV9saW5rIjoidXJsOmh0dHAlM0ElMkYlMkZsb25nLW1vY2tpbmdiaXJkLnc2Lndwc2FuZGJveC5wcm8lMkZ3ZWItZGV2LWVuZyUyRnx8fCJ9fQ=="][/vc_column][/vc_row]</p>

I am escalating the issue to our compatiblity team but we will need to cooperation of Uncode/WP Bakery in order to solve this issue. Please have some patience. I will get in contact as soon I receive feedback.

Kind regards
Andreas

August 13, 2019 at 6:46 am #4385363

mennoB-4

thanks for your reply Andreas,

" For now those links will need to be edited manually to each page in respect to their language"

How should I do to edit these links manually?

thanks, best regards

August 13, 2019 at 7:33 pm #4390403

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

We are currenlty working on a fix for the issue.

In the meantime try the follwing:

1) Enter the page editor for your default languge page
2) Change the language in the top admin bar to English (flag)
3) Click "Edit anyways" on pop-up
4) Now, edit the Media Gallery item for the English page manually
5) Go to single block and edit the link URL with the respective Job page.

Let me know if this is a suitable workaround in the meantime. It worked on my test.

Kind regards
Andreas

August 19, 2019 at 8:06 am #4414287

mennoB-4

Thanks for your comments

August 19, 2019 at 7:03 pm #4418647

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I hope the manual workaround solves the issue on the meantime.

We are still investigating about the issue. I will be in contact as soon we can provide a fix.

Kind regards
Andreas

August 20, 2019 at 12:00 pm #4423359

mennoB-4

thanks, it's working

August 20, 2019 at 3:05 pm #4424781

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for letting me know.

I will be in contact once we can provide a working fix for the issue. Thank you for your patience.

Kind regards
Andreas