This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Shekhar Bhandari 4 months, 1 week ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 29, 2019 at 12:04 pm #3915271

Michael

I am trying to:
work with DIVI theme and i created a 2nd language / translation for my spec. page. now i want to import a already existing page (or saved layout) in the translated spec. page. but it does not show up. hope you can help me out with this. i had that issue with another site half a year ago ...and could manage it ...but now idont recall it anymore.

here is a clip for better explanation: hidden link

Link to a page where the issue can be seen:
hidden link
I expected to see:
...
Instead, I got:
...

thanks in advance and
kind greeetings,

Michael

May 30, 2019 at 6:52 am #3920799

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

I would like to direct you to a relevant article from our documentation which should contain all the information you need to know.
https://wpml.org/documentation/theme-compatibility/divi-builder/#translating-divi-custom-layouts

If there is anything missing, or you'd like clarifications, I am here to help. Just drop a reply here so I can help you further.

Let me know if this helps.

Thanks

June 3, 2019 at 10:51 am #3941701

Michael

Hi Shekhar,

thanks for your reply and sorry for my late reply.
no it did not help really. but i did it like

just created the 2nd language page itself. and then connected the 2nd lang. page with the corresponding 1st lang. page within the "Edit Page" area where Wmpl is located...right sidebar.

that worked also.

but one issue is still there:

i have as my footer "global saved" rows. so i just created this global rows (footer and a socket) for the 2nd language page and when i then assign LINKS to that sections...then i can save them as for example:

hidden link
but when viewing on frontend - it shows always: hidden link

and thats neither the correct url ...nor would it be okay in terms of seo.
i also checked the settings--permalinks and saved it again. no result.

the url where the error is seen: hidden link
thats the 2nd language (engl.). the first language hidden link works fine.
would love to have your tip on that!
thank you in advance and

kind greetings Michael

June 3, 2019 at 11:06 am #3941787

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I am not sure how the footer is created, so to further debug this issue, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

June 4, 2019 at 11:46 am #3951129

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can see you are using an outdated version of the divi theme, could you please update the theme to the latest version and let me know if that helps?

NOTE:

+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

Once update, I request you to update all the links in sticky links options.

Look forward to your reply.

Thanks

June 6, 2019 at 1:56 pm #3969731

Michael

Hi Shekhar,

i did update divi and tested again with updated link. no result so far.

kind greetings,
michael

June 7, 2019 at 11:27 am #3975859

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for the tests.

It looks like a compatibility issue with the theme. To debug compatibility issue quickly, it will be best to test the issue on a fresh new Installation, being so I would need your little help to pinpoint the issue further.

I have created a fresh new WordPress Installed test site here, hidden link you can click on the link to login.

Could you please use the same settings there and see if you can replicate the issue? Please don't use personal information on the site as it's a test site, I recommend using some dummy data.

This will help us to figure out if this is actually a compatibility issue or a site-specific issue.

Look forward to your reply.

Thanks

June 7, 2019 at 11:48 am #3975999

Michael

Hi Shekhar,

so first thing is the login. i do have the login-name of yours. but not the password. as i just sent that to you via that secure and priv. form ...so i dont see it. (of course wordpress hides that)

and then: have you divi installed on that test site?
its a divi issue and global sections... with the link problem ...

thanks for consideration Shekhar and
kind greetings,
Michael

June 7, 2019 at 12:46 pm #3976305

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

With the link provided, you can directly login to the site and install plugins/themes, please configure the site accordingly with demo content so we can confirm the compatibility issue.

Look forward to your reply.

Thanks

June 7, 2019 at 1:28 pm #3976717

Michael

Hi Shekhar,

so you tell me that i should install a demo website for you? as you are the one who should give me support? as a paying client of WPML that appears wierd to me.

btw. i already sent you the login credentials to the site itself. also i assume have the archive and installer files with the private upload form completed ...days ago already. is that correct?

thankyou,
michael

June 10, 2019 at 6:24 am #3985349

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Yes, I have the login details and the duplicator file.

I already installed the site and debugged the issue further, also I created a fresh new install and tried to replicate the issue but couldn't reproduce it so I was asking if you can try on a fresh install to see if it exists, this helps us to figure out if it's a compatibility issue.

Also, you don't need to set up the whole demo site for this, you can just use the same settings for a divi theme and create a sample layout to import to show us the issue.

I further debugged your site. After debugging it looks like a compatibility issue with Divi + WPML sticky links. Also, these two steps solve the issue in your test site so could you please use one of them and let me know if that helps?

- Deactivate WPML sticky links and reedit the content
- Use WPML translation editor to translate the content
https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/

Kind Regards,
Shekhar

June 11, 2019 at 9:51 am #3993759

Michael

hi again,

i tried to deactivate the sticky links plugin. that worked fine. thumbs up and

have a good day. thank you.
Michael

June 11, 2019 at 10:11 am #3993979

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Happy to help, you can mark the ticket as resolved now.

Thanks