Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 11 replies, has 2 voices.

Last updated by Andrés 11 months ago.

Assigned support staff: Andrés.

Author Posts
November 25, 2019 at 2:05 pm #5014503

patrickC-36

Bonjour,
j'ai migré les traductions de mon site de xtranslate vers wpml, tout m'a l'air de fonctionner mais je n'arrive pas à ajouter un sélecteur de langue dans le menu.
Impossible d'ajouter le selecteur via la section langue comme il est indiqué sur la documentation.
Il ne passe rien rien dans la section "Sélecteur de langue du menu", quand je clique sur le bouton "+ Ajouter un nouveau sélecteur de langue au menu" ...
Merci de votre aide

November 25, 2019 at 2:53 pm #5014783

patrickC-36

Maintenant le bouton "+ Ajouter un nouveau sélecteur de langue au menu" ne s'affiche même plus ...

November 25, 2019 at 5:15 pm #5015911

patrickC-36

J'ai aussi essayer d'insérer <?php do_action('wpml_add_language_selector'); ?> dans le menu entre les balise <nav> pas plus de résultat...

November 26, 2019 at 9:32 am #5019591

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

1. Pouvez-vous vérifier d'avoir déjà un menu crée dans le Bureau > Apparence > Menu ?

2. Pour pouvoir vous aider plus rapidement, j’ai activé l’information de debug pour ce ticket. Merci de regarder ce lien pour savoir comment obtenir plus d’information de votre site et nous la fournir.
https://wpml.org/fr/faq/comment-fournir-des-informations-de-debogage-pour-une-assistance-plus-rapide/

Cordialement,
Andrés

November 26, 2019 at 9:54 am #5019819

patrickC-36

Merci pour votre réponse,

1/ oui j'ai bien un menu déjà crée

2/ Voici les info de debug :
Avez vous bien reçu les infos de debug ?
Merci pour votre réponse,

1/ oui j'ai bien un menu déjà crée

2/ Voici les info de debug : avez vous bien reçu les infos de debug je ne les vois pas dans la discussion ...

November 26, 2019 at 9:59 am #5019845

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

1. Pouvez-vous ajouter une capture d'écran des options disponibles dans WPML > Langues ?

2. Cela serait très utile si vous pouviez me fournir l'information du debug.log de WordPress, pas l'information de débogage de WPML.

Est-ce que vous pouvez ouvrir le fichier wp-config.php et chercher la ligne: define(‘WP_DEBUG’, false); et la remplacer par:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Après, est-ce que vous pouvez chercher dans le dossier /wp-content/ s'il existe un fichier debug.log.
Pourriez-vous copier et coller le contenu du fichier debug.log dans pastebin.com et me fournir le lien, cela serait très utile (C'est la manière plus simple car parfois les logs sont volumineux et polluer notre conversation sur ce forum).
https://wpml.org/documentation/support/debugging-wpml/

November 26, 2019 at 10:22 am #5020045

patrickC-36

1. les voici ci joint

2. je viens d'activer le mode debug selon vos recommendation dans wp-config.php mais je n'ai pas trouvé de fichier debug.log dans le dossier wp-content.
J'ai esssayé de créer le fichier debug.log manuellement mais il reste vide...

November 26, 2019 at 11:54 am #5020963

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

D'après votre capture d'écran il semble d'exister une erreur fatale, très probablement lié à votre version de PHP.

Pouvez-vous contacter votre service d’hébergement et / ou la mettre à jour ?
https://wpml.org/home/minimum-requirements/

November 26, 2019 at 1:50 pm #5022025

patrickC-36

C'est bien ce que je pensais aussi,
J'ai déjà fait la demande...
Merci

November 26, 2019 at 2:13 pm #5022163

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Parfait, j'attends votre retour.
Cordialement

November 30, 2019 at 5:53 pm #5047857
patrickC-36

Bonsoir,

Nous en avons profité pour changer de serveur vers ovh avec la version php 7.2 d'activé
J'ai donc fais la migration du site, mis à jour wordpress , et fais la la mise à jour du plug in wpml, mais je rencontre d'autre problèmes.

Voici les deux problèmes :
1/ Les langues apparaissent dans le header en plus du selecteur.... voir impression écran.

2/ Quand on clique sur un langue autre que le français, on atterris sur une erreur 404.
Toutes les pages traduites mènent vers des erreurs 404.

Merci de votre aide

New threads created by Andrés and linked to this one are listed below:

https://wpml.org/forums/topic/split-impossible-dafficher-selecteur-de-langue/

December 2, 2019 at 6:42 am #5050801

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour,

Je suis ravi de savoir que votre problème initial a été résolu.

Or, par rapport à nos règles de support, nous devons gérer un seul incident par ticket, ça nous permet d'améliorer notre service et permet à d'autres utilisateurs de bénéficier des informations exposées. Pour cette raison je viens d'ouvrir un nouveau ticket.

Cordialement