This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 13 replies, has 2 voices.

Last updated by Carlos Rojas 1 week, 3 days ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 2, 2019 at 2:46 pm #4681623

marcN-8

I have a huge performance problem with WPML plugin
You can see on the images attached the performance with WPML activate and desactivate.
I use the plugin Query Monitor for this.

I followed those improvements but the problem is still here
https://wpml.org/forums/topic/site-speed-and-slow-queries/
https://wpml.org/forums/topic/slow-action-load-times-and-slow-queries/
https://wpml.org/forums/topic/very-slow-load-times-all-the-slow-queries-come-from-wpml/

the problem page is this one : hidden link
But the problem is on most pages

October 3, 2019 at 7:21 am #4685027

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Kind regards,
Carlos

October 3, 2019 at 10:14 am #4686699

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for the information provided.

I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Regards,
Carlos

October 3, 2019 at 12:21 pm #4687519

marcN-8

Hi,

I followed each step, performance is slightly improved when all plugins are disabled (except for WPML). I win about 2 to 3 seconds max but front is still slow and back office too.

In fact, the back office is worst than the front.

Changing theme do nothing.

October 3, 2019 at 12:41 pm #4687705

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

In this case I kindly ask you to activate the debug mode in the site by following this steps: https://wordpress.org/support/article/debugging-in-wordpress/ and check if there are any errors in the debug.log file that can be found within wp-content folder.

Regards,
Carlos

October 3, 2019 at 12:50 pm #4687821

marcN-8

Already did.
The only thing I have in my log is this :

PHP Deprecated: Function create_function() is deprecated in /kartcom/wp-content/plugins/wp-all-import-pro/classes/config.php on line 47

October 4, 2019 at 8:05 am #4693841

marcN-8

Hi,

I have this error when I try to migrate the website.
Also, what should I put in Application Folder Name ?

October 4, 2019 at 11:40 am #4695303

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I kindly ask you to put the 'Database Name' value in the 'Application Folder Name' field, fill the rest of the fields and double check if the issue persists.

Regards,
Carlos

October 4, 2019 at 2:18 pm #4696413

marcN-8

I'm sorry but this is not working (see image attached) 🙁
Can you take a look please ?

My files and my database are saved, you can try yourself if you want.

October 7, 2019 at 9:11 am #4705775

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I tried to migrate the site several times but the issue persisted so I applied some troubleshooting steps in the site and now the performance has improved. However I kindly ask you to contact your hosting providers and ask them to re-start the server in order to avoid another memory problem.

Could you double check the site after the server's restart?

Regards,
Carlos

October 7, 2019 at 9:53 am #4706023

marcN-8

Hi,

My hosting provider restart apache server.
Performance has indeed improved (see image attached).

Can I ask you what changes you have made ? because this website will be migrated to another server when it will be in production.

October 7, 2019 at 12:18 pm #4707019

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I deactivated a plugin that was causing an error (you can see the errors in debug.log file) and then I went to WPML -> Support -> Troubleshooting -> Applied the troubleshooting steps highlighted in the attached image.

Regards,
Carlos

October 7, 2019 at 12:23 pm #4707047

marcN-8

My issue is resolved now. Thank you!

October 7, 2019 at 1:31 pm #4707821

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos