This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.66 hours from now. Thank you for your understanding.

This topic contains 11 replies, has 2 voices.

Last updated by Carlos Rojas 1 week, 4 days ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 25, 2019 at 11:03 pm

andresA-15

I am trying to: translate home page

Link to a page where the issue can be seen: hidden link

I expected to see: When load home page scroll down a little and se categories loading

Instead, I got: when i load home page in anthoer language than the main one it fails to show the product categories loaded by shortcodes in home.

September 26, 2019 at 12:12 pm #4646681

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I can see that the products nor the products categories are translated. In this case you need to translate the products and its categories in order to be able to show then in the secondary language.

On the other hand, if you are not planing to translate the products you can show them as translated by following the steps described here: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

September 26, 2019 at 6:49 pm #4649785

andresA-15

Hi,

I have increased the PHP Memory Limit, and i don't want to translate all product and categories so i did the change in wpml setting for Displaying Untranslated Content on Pages in Secondary Languages but it is still not working,

Is there any other thing i can do to fix this ?

September 26, 2019 at 8:20 pm #4650149

andresA-15

There is something else to say after the change only one product category is displaying fine but the rest are not showing

September 27, 2019 at 11:15 am #4653681

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I ran some tests but the issue persists. Could you create a test site with a copy of the production site so I can run further tests without affecting the live site?

Regards,
Carlos

September 27, 2019 at 10:38 pm #4656811

andresA-15

Hi sure,

I just created the test site, how do i share those access to you ?

September 30, 2019 at 8:41 am #4663025

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you for creating this test site.

I have set your next answer private and there you will find the fields to provide the credentials in a secure way.

Looking forward to your message.
Regards,
Carlos

September 30, 2019 at 4:42 pm
October 1, 2019 at 10:33 am #4671059

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

After several tests I found that the cause of the issue. Please follow this steps:
- In the test site go to WPML -> Settings -> Post Type Translation -> Look at the Products and Variations, and apply the same configuration to the live site.
- In the test site go to WPML -> Settings -> Taxonomies Translation -> Apply in the live site the same configuration of the 'Product categories (product_cat)'.
- In the live site go to Products -> Categories -> Translate the categories that appear in the homepage, for instance: 'Gemstones'. You can see this product category translated in the test site.
- Edit the homepage in English -> Re-save it -> Update the translation in Spanish.

Could you confirm that the issue is solved?

Regards,
Carlos

October 2, 2019 at 2:55 pm #4681717

andresA-15

Sorry i was very sick yesterday and i couldn't check i will check today though, thanks a lot.

I have a questions if i would like to translate just a few products is there a way to do a bulk translate because in teh screen it only allows me to trasnlate by one.

October 3, 2019 at 6:24 am #4684801

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
I hope you feel better today 🙂

There is no way to translate in bulk, but you can Duplicate products in bulk in WPML -> Translation Management: https://wpml.org/documentation/translating-your-contents/

Best regards,
Carlos

October 4, 2019 at 11:17 pm #4698803

andresA-15

My issue is resolved now. Thank you!

October 7, 2019 at 8:26 am #4705411

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos