This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by simoneL-13 5 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
May 2, 2019 at 2:11 am #3720611

simoneL-13

I have received an error saying in isset or empty in /home/richclic/public_html/stagingsite/wp-includes/pomo/translations.php on line 91

The theme has been fine up until recently i tried to translate a page and the error occurred

May 2, 2019 at 5:48 am #3721923

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

=== Please backup your database and website ===

2. You are using older version of WPML plugins. Please backup your site and update ALL WPML plugins to it's latest versions. You can download it from your account: https://wpml.org/account/downloads/

3. Please make sure your theme is WPML compatible. Here is our compatible theme list. You can search your theme in this list. https://wpml.org/documentation/theme-compatibility

4. Also make sure you are using an updated version of the theme and plugins.

5. Please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

If the issue is gone, activate one by one to see which one there is an interaction issue.

Please let me know the results.

Thank you

May 2, 2019 at 12:43 pm #3724619

simoneL-13

Thank you , i added the memory to the config file and it has resolved the issue, i will still update the plugins however issue seems to be resolved