Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Otto 4 years, 11 months ago.

Assigned support staff: Otto.

Author Posts
November 3, 2015 at 8:00 am #738022

patrizio-romanoD

Yesterday i was trying to integrate WPML in my multisite network and now wpml is not working at all. I'm not using many plugins and my installation is practically a vanilla one.

I'm Using Domain Mapping from WPMU dev.

let me explain you what I did:

1. Manually Backup everything
2. Installed WPML (Uploaded the files via FTP, then network activated it)
3. As I don't wanted my actual clients to see that I'm activating WPML I deactivated it from the network admin console for a couple of sites
4. After doing the steb-by-step configuration I visit to my main network homepage and realized that it was a 404
5. I control the pages on my website (the main network) and see that all my pages wasn't there anymore although they showed up in the "All Pages" counter
6. Looking around your forums i find a post that suggested to do some cleanup on troubleshooting page
7. After doing what suggested, the "missing pages" issue continued so i decided to perform a reset from the network admin wpml console but as soon as I click on that "reset" link i got a message like this: "You do not have sufficient permissions to access this page"
8. And as soon as i return to the admin page I don't see the wpml menu anymore
9. I deleted the files via ftp and then reinstalled, this time activating it on a site-by-site basis but it just doesn't work at all.

I have nothing on the error logs that helps me to understand what could be wrong.

I hope you can help me.
Thanks in advance

November 3, 2015 at 6:08 pm #738732

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you for contacting the WPML support!

Does it works if you deactivate Domain Mapping?

Can you please check in your Database if you have WPML tables (icl prefixes)? And also if there are some values within wp_options table (search also for icl).

I´ll wait for your information.

Kind Regards

November 3, 2015 at 7:22 pm #738794

patrizio-romanoD

Thanks Otto, I've already removed _icl_ prefixed tables but i need to remove the wpml stuff on options tables (for each subsite too, isn't it?) entries that honestly don't know exactly which ones they are.

Can you please point me in the right direction? How can I find The wpml related options and eventually, how can I remove all those modifications. Manually.

Thanks

November 3, 2015 at 8:15 pm #738827

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Please take a look at this thread:
https://wpml.org/es/forums/topic/he-activado-el-plugin-para-un-sitio-wp-multisite-y-ahora-no-funciona-en-otros/page/2/#post-736715

Let me know if it helped.

Kind Regards

November 4, 2015 at 11:16 am #739257

patrizio-romanoD

Ok, i opted for a restoring of the pre-wpml database and files.
So Let's start clean this time.

I don't want to encounter the same problems again though.

- Is there an optimal way to perform the install on a multisite network which already have domain mapping?
- Do I need to do something on the sunrise.php as I already have a sunrise from wpmudev's domain mapping plugin?

In my multisite there are some sites which have "default languages" on English and others in Italian, could be this a reason for troubles in the install?

Following for your answer and thanks for your support

November 4, 2015 at 1:29 pm #739403

patrizio-romanoD

Ok, I think I've solved the issue 🙂
I reinstalled everything and then I went to troubleshooting and pressed the "Set Language Information" button.
Now it works as expected.

November 4, 2015 at 1:50 pm #739423

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Great 🙂 !

If you find some other issues please open a new ticket.

Kind Regards