Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Lauren 1 year, 6 months ago.

Assigned support staff: Lauren.

Author Posts
May 31, 2018 at 8:34 am #2254889

patrizio-romanoD

Today a client of mine informed me about a weird issue with the language switcher in the homepage.

This is the website : hidden link

If you navigate to the footer you can see that the language switcher points to a wrong URL (The network subdomain url) but if you navigate to another page the language switcher behaves as expected.

...I'm literally going out of my mind with this, any help is welcome.

Thanks in advance

June 1, 2018 at 2:10 pm #2261607

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

When I use the language switcher in either the footer or the header, it works correctly for me. When I click English, it takes me to hidden link and when I click Italian, it takes me to hidden link. Can you please tell me if you have different results? Please be sure to test in a browser that has a cleared cache.

June 9, 2018 at 6:55 am #2401633

patrizio-romanoD

Sorry, missed the notification email.

The problem is that the link is not relative to the mapped domain but to the network site so if I need to activate https everything breaks 🙁

hidden link

June 11, 2018 at 2:00 pm #2405262

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Please go to Settings -> General and check to see if the https is entered in the Site URL and the WordPress URL. Also check the .htaccess file and wp-config.php file to see if the homepage URL is defined there, and if so, try removing it to see if that resolves the issue.

If it does not, I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

The topic ‘[Closed] In Multisite + Domain Mapping Language switcher doesn't work in homepage’ is closed to new replies.