This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Radu 2 months, 3 weeks ago.

Assigned support staff: Radu.

Author Posts
July 19, 2019 at 7:59 am #4244797

leonidoG

I am trying to:

Link to a page where the issue can be seen: please send me an IP so I can whitelist

I expected to see:

Instead, I got:

July 19, 2019 at 8:11 am #4244831

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Thank you for reaching out the WPML support!

The IP that you can whitelist is 74.50.54.81. Please don't forget to attach a link to your website too.

Thanks,
Radu

July 19, 2019 at 8:13 am #4244837

leonidoG

The IP is now whitelisted.
hidden link

July 22, 2019 at 9:28 am #4255467

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Can you make sure that this IP is added to the whitelist, please? I'm asking for this because I tried to access the website but I still get the This site can’t be reached message. If there's anything else I need to do in order to see the website, please let me know.

Thanks,
Radu

July 22, 2019 at 9:31 am #4255483

leonidoG

My apologies. Its: hidden link

July 22, 2019 at 1:00 pm #4257569

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

No worries. Now I was able to see the website. As I understand from your message, the language switcher (I guess the one from the top left side of the page) is still showing, even though you set all the options from WPML not to do that. In this case, please give me access to the dashboard area of the website and I'll have a closer look at this. I'm sure that we'll be able to sort this out in no time.
The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

July 23, 2019 at 10:26 am #4265101

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Thank you for giving me access to the dashboard area. I checked things out a bit closer and it seems that the Sweetdate theme is the one that's adding the language switcher at the top of the page. The code that's doing this is:

add_action( 'kleo_before_top_links', 'kleo_language_selector' );

function kleo_language_selector() {
	if ( defined( 'ICL_LANGUAGE_CODE' ) ) {
		do_action( 'icl_language_selector' );
	}
}

and it's added to the functions.php file.
According to the Remove_action filter documentation https://codex.wordpress.org/Function_Reference/remove_action#Example, you can use some code like

add_action( 'wp_head', 'remove_language_selector_action' );
function remove_language_selector_action(){
	remove_action( 'kleo_before_top_links', 'kleo_language_selector' );
}

to get rid of that language switcher. You can give it a try but first, please create a full backup of your website. Just let me know how it works 🙂

Thanks,
Radu

The topic ‘[Closed] In my theme the langauge switcher is showing even when i deactivated all in wpml’ is closed to new replies.