Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

No supporters are available to work today on this forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 22 replies, has 3 voices.

Last updated by Mateus Getulio 4 weeks, 1 day ago.

Assigned support staff: Mateus Getulio.

Author Posts
April 13, 2021 at 5:41 pm #8527981

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Fabio,

Thanks for your patience.

Upon further inspection, we've found a workaround that solves the issue in the staging site that you provided. Please check the string "Must accept privacy policy conditions": hidden link, as a test, we’ve added a ‘it’ to the end of that string in the Italian version of the site.

At this point, we'd like to test the solution on the live version: hidden link. Could you please send us the access data? I'm marking your next reply as private.

Thanks,
Mateus.

April 14, 2021 at 3:15 pm #8536777

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Thank you for the credentials.

We were able to apply this same workaround in one of your website's problematic strings, and now it is displaying the translations rightly. Please check the string "Must accept privacy policy conditions": hidden link

As the same test, we've added an 'it' to the end of that string in the site's Italian version. You can follow the instructions of the workaround described in this errata to apply the fix in the other strings:

https://wpml.org/errata/in-some-cases-some-strings-are-not-translating-properly/

- First, find the problematic string in WPML -> String Translation page and delete it
- Go to WPML -> Theme and plugins localization -> Strings in the themes, select your theme and then scan it
- Re-visit the WPML -> String Translation page and search for that string
- Translate the string

Check if the translations display correctly now. Please also make sure to clean/disable all caches. Let me know if these steps work for you.

Best,
Mateus.

April 15, 2021 at 8:18 am #8541741

Fabio

I've done exactly what you said but the string "The redeem code is not valid or it was already used. Double check it and try again." appears only in english. I have cleaned all caches. The funny thing is that if i export the .po file from WPML the string is correctly translated (see screenshot).
I also slightly changed the message to "The redeem code is not valid or it was already used, double check it and try again." but the error is still there.

I also noticed that in the english version of that page (hidden link) the form is in Italian and this does not make any sense at all because all strings in php are in english.

Is there a way to overwrite these strings with .po/.mo files?

These problems are really serious and are impacting my client website. We need a fix ASAP.

Schermata 2021-04-15 alle 10.07.28.png
April 15, 2021 at 8:38 am #8542241

Fabio

It's not a fix, but i'm trying moving all these strings in an ACF option page and set the translations from there. These strings translation seems really broken.

April 15, 2021 at 9:24 am #8542723

Fabio

Ok maybe i found a solution: i changed the string directly in the theme's .po file and translated via String translations.
The theme's po file has a direct reference to #: php/qtheme-fork-functions.php:437 with the old string.

Now it seems to works, but there's another problem: the page in english and spanish has the form in italian: hidden link hidden link

April 15, 2021 at 6:34 pm #8548349

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

We're sincerely sorry to hear about the continued issues with this.

We'd like to take a second look at the other strings in which the workaround didn't fix the problem.

Are you able to restore a back up from a point before the changes with the mo files and the ACF option page? If possible, we'd like to double-check the workaround in the errata with the other strings from a checkpoint before those last changes were made.

Thank you, please let us know.

April 16, 2021 at 2:49 pm #8556785

Fabio

You can check on the dev website, but i can explain what happened.
In the .po file in the theme folder there was a reference for the php/qtheme-fork-functions.php file on row 437 with msgid "The redeem code is not valid. Double check it and try again."
When i changed the string in php/qtheme-fork-functions.php at line 437 with the new string, the .po files wasn't updated so i think there was a conflict by the .po file an the string translation plugin.
Now this problem is solved, but there's another problem: the form on page hidden link is in Italian also in english and spanish, but in the other languages is translated.
Many thanks

April 16, 2021 at 7:03 pm #8558603

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Upon further inspection it seems like there was a .MO file placed at wp-content/themes/zeroco2/lang that was causing some conflicts with the English and Spanish versions of the form.

The strings available in there were getting priority over the translations made within WPML's String Translation, causing the issue you were experiencing.

We temporarily renamed that folder in order to force WPML to serve the strings coming from String Translation.

After that, we tested every version of your form and so far we haven't been able to spot any issues left.

Can you please test it again and tell us how this is looking on your end now?

Thanks, please let us know!

Mateus