This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Riffaz 2 months, 1 week ago.

Assigned support staff: Riffaz.

Author Posts
August 6, 2019 at 3:22 am #4343979

iwonaK-5

I am trying to: opem drop down menu in the top of my page

Link to a page where the issue can be seen:hidden link

I expected to see: that dropdown menu in the top will show me other languages that i can choose them. like menu in footer

Instead, I got: menu in top of my website is locked on polish language and i cant choose any other

August 6, 2019 at 3:30 am #4344053

iwonaK-5

Now I notice that i also can not change type of list. no matter if i choose vertical, horisontal or dropdown its just not changing and not working.

August 6, 2019 at 4:33 am #4344121

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

The other languages flags appear when there is a translation already.

Can you please add a translation to the page and check if the issue persists?

Alternatively, you can go to WPML > Languages > Language switcher options > How to handle languages without translation > "Link to home of language for missing translations"

Let me know if this helps, please.

Kind regards,
Riffaz.

August 6, 2019 at 5:21 am #4344241

iwonaK-5

of course there is translation. I think you even didnt check. In footet there is no problem. Just in top bar. Please read one more time the message which i send before.

August 6, 2019 at 5:22 am #4344267

iwonaK-5

in footer switcher there is no problem. just top bar switcher has some issue.

August 6, 2019 at 6:44 am #4344443

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I checked your footer before replied. It did not work but it works now. Not sure why.

The language switcher at the top is not in the menu, right?
This is your menu hidden link right?

Could you please try to add another switcher to menu and check?
Let me know if that works or not.

Regards,

August 6, 2019 at 6:56 am #4344523

iwonaK-5

Footer is workin. If i add switcher in menu it is also working just in top bar is not working.

August 6, 2019 at 7:00 am #4344601

iwonaK-5

It was working before, i think after last update its not working i just noticed it today.

August 6, 2019 at 7:36 am #4344703

iwonaK-5

are you there?

August 6, 2019 at 7:54 am #4344807

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I do not see any errors in console either: hidden link

I think after last update its not working
- you mean WPML update?

You are using Consultix 1.3.5
The last version of Consultix is 1.3.7 : hidden link
And, the theme was not updated for an year.
That could be the issue.

After update the theme, disable all the third party plugins and check the issue.
If you can check with theme support as well.

Let me know how it goes.

are you there?
- yes, I am here.
- I have to spend some time debugging your issue, checking themes, plugins and guess the possibilities of this issue.
- of course that will take some time.

Regards,

August 6, 2019 at 8:25 am #4345093

iwonaK-5

I think after last update its not working
- you mean WPML update?

Yes, It was working with this version of theme before.

August 6, 2019 at 12:16 pm #4347251

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

The top switcher works when you click on it: hidden link
Is this ok now?

Regards,

The topic ‘[Closed] In the widget menu on the top of my website i can not choose language. Its locke’ is closed to new replies.