This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Translation is not saving in Advanced Translation Editor when it has ACF shortcode(when removing it)

Solution: This is an expected result. Because the Advanced Translation Editor is designed like this. It tries to remove all HTML/shortcodes and keep only relevant and translatable content. In some cases, inside meaningful translatable content (sentence) there is either HTML content, either shortcode. Those are removed by the editor and replace with visualization (colors for HTML tags around text) and some placeholders for inline elements. During translation, you just have to keep those placeholders in the right place.

For example, we have an image or a placeholder that adds some symbol in a sentence like this:

As can be seen in [complicate_shortcode_code_to_show_image] there are 3 yellow cats

In Advanced Translation Editor *complicated_shortcode_code_to_show_image* is replaced with a placeholder that has to be moved at the right place in translation (not in all languages it will exactly after the fifth word, so it is up to the translator to put it at right place).

Removing that placeholder from the translation is not possible. Advanced Translation Editor ensures the integrity of translation by checking that has exact same HTML structure and exact the same number of HTML tags and shortcodes.

Relevant Documentation:

0% of people find this useful.

This topic contains 10 replies, has 2 voices.

Last updated by malteP-2 1 year ago.

Assigned support staff: Bigul.

Author Posts
September 23, 2018 at 5:42 pm #2758868

malteP-2

I am trying to: translate a sentence from a german post to english with a custom shortcode. This shortcode is only relevant in the german post, not in the english one. So I don't want to use this shortcode in the english sentence.

I expected that I can write a translation without my custom shortcode.

Instead, I got this error message: Translation not saved: The original sentence includes formatting markers. However, not all markers are applied to the translation hidden link

How can I fix this issue?

Thank you!

September 25, 2018 at 9:04 am #2763106

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Are you translating the Post using WPML Translation Editor or a translation service like ICanLocalize?

Please try the following steps as a workaround and check the issue is existing or not.

a) Visit WPML>>Settings
b) Scroll down to *How to translate posts and pages* section
c) Choose *Create translations manually* option
d) Save the changes
e) Then translate the Post manually into English. Please check this documentation as an example - https://wpml.org/documentation/translating-your-contents/page-builders/translating-content-created-with-page-builders-using-manual-translation/

If you are still having the issue, please share with me few screenshots for a better understanding of the issue.

--
Thanks!

Bigul

September 25, 2018 at 1:58 pm #2764139

malteP-2

Hello Bigual!

Thank you for your answer.

I am using the new Advanced Translation Editor (ATE) for myself, there is no translation service involved!

Of course, when I use the manual translation, I don't have this problem. But I want to use the new Advanced Translation Editor (ATE) because it's much easier to translate here with the help of the automatic translation. Isn't there a way to translate a sentence without all markers? I think it should be optional to use a marker in the translation.

Best regards,
Malte

September 25, 2018 at 4:34 pm #2764803

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Malte,

Thank you for the updates. Please share me the following details for tracking the issue.

a) Please share with me the Page URL you having the issue and few screenshots for a better understanding

b) Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

September 26, 2018 at 1:14 pm #2767381

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Malte,

Thank you for the login information and steps. But the site is not showing Advanced Translation Editor for the product because of the translation Jobs. I have a doubt *ACF* shortcode is replaced with <wpcodeself> in Advanced Translation Editor? Becuase <wpcodeself> shortcode is not showing in Product Contents field. Please check the attached images for more details.

I have a request. Please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

September 27, 2018 at 7:58 pm #2771710

malteP-2

Hello Bigul,

maybe you cannot use the Advanced Translation Editor (ATE), because of the license restrictions. I think, I only have one license for my account?

In your first screenshot you can see my advanced custom field shortcode [acf field="deutscher_reseller" post_id="option"]. This one is replaced with <wpcodeself> in the WPML Advanced Translation Editor (ATE) when I translate the post. I don't want this shortcode in my translation, but it's not possible to save the translation without the <wpcodeself> in the translation.

Please feel free to make a temporary local duplicate for debugging with the Duplicator plugin.

Could you also please delete your screenshots, because they are showing some details of my website (for example the URL)? Thank you!

September 28, 2018 at 1:00 pm #2773870

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Malte,

Thank you for the updates and permission. I made a Duplicator copy of your site. Will debug it further and get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

October 1, 2018 at 7:20 am #2777229

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Malte,

For your kind updates, the bug is existing after the initial Debugging procedures. But not able to reproduce the issue exactly in a fresh installation. Therefore I have forwarded the details to our second tier team for the expert opinion. We will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

October 2, 2018 at 4:12 pm #2782229

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Malte,

For your kind information, the bug is existing after our primary investigation procedures. Therefore I have escalated the ticket to our second tier team for further debugging.

We will get back to you as early as possible. Please wait.

--
Thanks!

Bigul

October 5, 2018 at 8:26 am #2789856

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Malte,

For your kind information, this is an expected result. Because the Advanced Translation Editor is designed like this. It tries to remove all HTML/shortcodes and keep only relevant and translatable content. In some cases, inside meaningful translatable content (sentence) there is either HTML content, either shortcode. Those are removed by the editor and replace with visualization (colors for HTML tags around text) and some placeholders for inline elements. During translation, you just have to keep those placeholders in the right place.

For example, we have an image or a placeholder that adds some symbol in a sentence like this:

As can be seen in [complicate_shortcode_code_to_show_image] there are 3 yellow cats

In Advanced Translation Editor *complicated_shortcode_code_to_show_image* is replaced with a placeholder that has to be moved at the right place in translation (not in all languages it will exactly after the fifth word, so it is up to the translator to put it at right place).

Removing that placeholder from the translation is not possible. Advanced Translation Editor ensures the integrity of translation by checking that has exact same HTML structure and exact the same number of HTML tags and shortcodes.

Thank you for the understanding.

--
Thanks!

Bigul

October 5, 2018 at 9:39 am #2790203

malteP-2

Hi,

I understand what you're saying. I just wish it wasn't mandatory to use a placeholder in the translation. But if you think that it is necessary for the integrity of the translation then it is like this.

I will try to edit the shortcode so that it doesn't return anything in the translation and then simply hang it at the end of the translation.

Thanks!