This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 24 replies, has 2 voices.

Last updated by Dennis 3 months, 2 weeks ago.

Assigned support staff: Dennis.

Author Posts
June 19, 2019 at 3:58 pm

Carel van der Wyck

I am trying to: I translate all my pages but in the frontend I can switch language and menu and footer switch language but the cornerstone content stays in Dutch. In the backend I have both Englisch and Dutch. Must be a little setting I think but can't find where

Link to a page where the issue can be seen: hidden link

I expected to see: content in English

Instead, I got: content in Dutch

June 20, 2019 at 1:55 am #4055609

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

We have a documentation on how to translate pages built by Cornerstone page builder. Could you please try to check it and review the following documentation?

https://wpml.org/documentation/theme-compatibility/xtheme/#translating-your-pages-built-with-cornerstone

Hope this helps.

Kind regards,
Dennis

June 20, 2019 at 8:37 am #4057699

Carel van der Wyck

Hi, Yes I read this documentation allready and everything is translated but in the frontend the cornerstone content stays Dutch...

June 20, 2019 at 9:05 am #4057835

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

I would like to request your permission to install Duplicator plugin, build a package and download a copy so I can continue debugging locally and without affecting your site. Please let me know if I can proceed.

Thank you.

Kind regards,
Dennis

June 20, 2019 at 9:38 am #4058393

Carel van der Wyck

Hi Duplicator is allready installed so take your copy! Thx

June 20, 2019 at 9:39 am #4058403

Carel van der Wyck

This is a develop location and I have a backup so you can try at this site also...

June 21, 2019 at 7:15 am #4065075

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

I have successfully created a duplicator package. I will download a copy and try deploy it on my local machine. Then I will continue debugging your site locally and will give you feedback when I got some results.

Kind regards,
Dennis

June 21, 2019 at 10:23 am #4066263

Carel van der Wyck

THX!

Succes and hope you find a solution soon. I think it must be something small...

June 21, 2019 at 12:19 pm #4067107

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Could you please change your PHP configuration as suggested on this article from X theme?

hidden link

Also, please increase the WP Memory Limit (your current setting is 40M). Minimum requirements are 128Mb:

https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Add it above the line

 /* That's all, stop editing! Happy blogging. */ 

Have you tried translating the page via WPML > Translation Management? If not could please try it? You can review the video in the documentation below:

https://wpml.org/documentation/theme-compatibility/xtheme/#translating-your-pages-built-with-cornerstone

I tried that method and it seems to work on my local copy of your site.

Please let me know how it goes.

Kind regards,
Dennis

June 26, 2019 at 11:19 am #4091907

Carel van der Wyck

Hi,

I moved all to a new server to your specs but still the same problem! Everything is translated with the classic editor I think. When I'm in a page with Cornerstone, I can switch to the other language with the flags in the right under corner and than the translation is there but there is no way to get this working in the frontend...?

Regards, Carel

June 27, 2019 at 6:50 am #4096919

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your updates.

Could you please take these steps and check if it resolves the issue.

-backup your site completely.
-go to Pages. Using the the language switcher on the admin bar, select 'English' to switch to English pages.
-delete the 'Menu' page. Also delete it from the trash.
-switch the language switcher back to Dutch.
-go to WPML > Packages. Select 'Page Builder Page 589'. 589 is the page id of Menu page in Dutch.
-click 'Delete selected packages' button.
-go to Pages. Edit the Menu page. Make sure to enable the 'Use WPML's Translation Editor' option on the Language metabox.
-click + Translate button. You may need to switch the content editor to text mode so you can see the html markups. Please see attached image. Save and close.

After following the above steps, I was able to display the English translation on front end. Kindly check the attached screenshot.

Hope this will also work on your end.

Kind regards,
Dennis

June 27, 2019 at 8:56 am #4098139

Carel van der Wyck

Hi,

When I click the + translation button, my translation opens in a different screen om hidden link See screenshot. Houw can I get the translation edititor text mode like the screen shot you send....?

Best regards, Carel

June 27, 2019 at 9:02 am #4098181

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

You can change the setting at WPML > Settings > How to translate posts and pages section. Select the option 'Use WPML's Classic Translation Editor'. Save.

Kind regards,
Dennis

June 27, 2019 at 9:06 am #4098257

Carel van der Wyck

Okay! I see! And now I have to translate all my pages this way again or is there a way to take alle translation I already made...? And how to do the other pages? How do I know what package to delete?

THX, Carel

June 27, 2019 at 9:17 am #4098389

Carel van der Wyck

So there is now way to use the translation button in Corberstone and to get that translation because that's much more easier with plugins in the pages...? Before that worked perfect!