Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
When renewing the subscription product WooCommerce Subscription order showing Payment processing skipped – renewal order created under staging site lock. when WPML is active and running Language per domain.

Solution:

  1. Define the site URL only the default domain of your website in wp-config.php in this way https://codex.wordpress.org/Editing_wp-config.php#WP_SITEURL
    define( 'WP_SITEURL', 'https://example.com' );
  2. Check the "wc_subscriptions_siteurl" key in the wp_options table and make sure it is same as original site URL including the trainling slashes if exist any.
    The URL will hold the placeholder like _[wc_subscriptions_siteurl]_ e.g. http://localhos_[wc_subscriptions_siteurl]_t
    Leave it as it is WP Subscription plugin removes it later.
  3. Clear all the caches and transient from WooCommerce.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 32 replies, has 3 voices.

Last updated by tomasP-10 1 year, 10 months ago.

Assigned support staff: Sumit.

Author Posts
September 21, 2018 at 3:31 pm #2755810

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I have checked on localhost by enabling the Subscription and disabling the GoPay plugin and I don't see any issue.

This is a very strange condition.
I have checked the subscription plugin code checking the duplicate site and they first look for "WP_SITEURL" constant and then calls the get_site_url() if it is not defined. WPML filter the get_site_url function when on secondary domain.

So it is possible somehow both the URLs are not matching. (However, you mentioned the CRON is being called from primary domain so it is not possible until someone hit the CRON URL manually)

Could you please try the following?
#1 Define the site URL only the default domain of your website in wp-config.php in this way https://codex.wordpress.org/Editing_wp-config.php#WP_SITEURL

define( 'WP_SITEURL', '<em><u>hidden link</u></em>' );

#2 Check the "wc_subscriptions_siteurl" key in the wp_options table and make sure it is same as original site URL including the trainling slashes if exist any.
The URL will hold the placeholder like _[wc_subscriptions_siteurl]_ e.g. hidden link
Leave it as it is WP Subscription plugin removes it later.

Clear all the caches and transient from WC and see if it fixes the issue?

Thanks

September 25, 2018 at 12:15 am #2761972

tomasP-10

Hi,

so I set siteurl in wp-config and cleared transients and it is going well. I am quite angry it was so f***** easy and still do not get why I had such a problem. It is working also when siteurl is not set, so it looks some transient did it... hope it is not gonna happen again.

Thank you for the support.

Sincerely,

Tomáš Pokorný

September 25, 2018 at 11:19 pm #2765338

tomasP-10

Hello,

the thread is not resolved. I thought it is okay, but today recurring payments did not proceeed. Staging site again. F**k this!!! I do not understand why it is not okay again.

September 25, 2018 at 11:28 pm #2765343

tomasP-10

It looks that it is not happening with new orders, but still with the old ones...

September 25, 2018 at 11:29 pm #2765347

tomasP-10

I have to disable your plugin again and work without it. Thank you for not resolving this issue for a month.