This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: In Translated pages Heading Fonts are appearing different then the primary language.

Solution: You are using Avada theme. In this theme you can translate fonts etc by switching different language using the Language Switcher in the top of the WP Admin panel.

Please go to Avada >> Theme Options > Typography and switch admin language from WP Admin bar and make sure you have selected same values in all languages. See screenshot: - https://cdn.wpml.org/wp-content/uploads/2018/10/2800059-En_language_typography.png?x59034 - https://cdn.wpml.org/wp-content/uploads/2018/10/2800059-Dutch_typography.png?x59034

Relevant Documentation: https://theme-fusion.com/documentation/avada/knowledgebase/how-to-set-different-theme-options-with-wpml/

This topic contains 4 replies, has 2 voices.

Last updated by aislingC 1 year ago.

Assigned support staff: Noman.

Author Posts
October 8, 2018 at 11:56 am #2795905

aislingC

I am trying to: have identical heading fonts appear on both versions of my site

Link to a page where the issue can be seen: hidden link

I expected to see: Exactly the same font (Montserrat) in the page title banner and heading of the body text.

Instead, I got: hidden link

October 9, 2018 at 11:55 am #2799828

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. We can fix that using some Custom CSS. I am inspecting your site right now and will get back to you with the solution asap.

Thank you

October 9, 2018 at 1:07 pm #2800059

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I see you are using Avada theme. In this theme you can translate fonts etc by switching different language using the Language Switcher in the top of the WP Admin panel.

Could you please go to Avada >> Theme Options > Typography and switch admin language from wp admin bar and make sure you have selected same values in all languages. See attached screenshot.

Here is doc for more details:
hidden link

If still issue persists, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

October 9, 2018 at 3:15 pm #2800739

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for providing login info. I logged into your site and see that you are using old version of Avada theme. Please backup your database and site, then update theme to the latest version v5.7
hidden link

- Also make sure Fusion Core and Fusion Builder plugins are also up-to-date, these are included within Avada.

- After above updates, then try to follow the steps I mentioned earlier and please let me know the results.

Thank you

October 9, 2018 at 3:46 pm #2800922

aislingC

My issue is resolved now. Thank you!