Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The hreflang is not displaying correctly in the secondary language.

Solution:

On this ticket, this was not being displayed correctly because the client had not translated the site content.

The hreflang is only displayed when the post/page content is translated. Otherwise, having only a single language, hreflang, is not required and therefore is not displayed.

This topic contains 7 replies, has 2 voices.

Last updated by marcg-20 2 years, 10 months ago.

Assigned support staff: Bruno.

Author Posts
March 3, 2017 at 11:53 am #1221754

marcg-20

Incorrect hreflang implementation on hidden link

March 3, 2017 at 7:34 pm #1222149

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us.

Please as a test, could you disable all non-WPML plugins and see if the problem persists?

Also, if your server is using some caching system, could you please clear the cache and see if the problem persists?

Thank you.

March 4, 2017 at 12:41 am #1222235

marcg-20

I disabled plugins and cleared the server cache but the problem persists

March 6, 2017 at 6:27 pm #1223649

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

March 8, 2017 at 2:37 pm #1225450

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. This problem is happening because you do not have any posts created in the secondary language. For this reason, hreflang is not being displayed in the secondary language.

Please, could you translate a content from Posts > All Posts to see if hreflang tag will be displayed? You can, for example, translate or duplicate the FAQ page, even if the page is empty.

After following the above step, please let me know if the problem persists or if the hreflang tag in the secondary language is being displayed correctly.

Thank you.

March 9, 2017 at 2:19 am #1225883

marcg-20

I have added posts as suggested but the issue is not resolved. If you look at the attached below the flag should be a pencil i believe but its not.

March 9, 2017 at 12:27 pm #1226340

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. The "processing" icon shows that the content was sent to translation, but it was not translated. This appears as "In progress" but no translator actually translated the content.

I've just translated that content (I've copied the content to the secondary language). Please, could you verify that the problem is resolved?

Thank you.

March 13, 2017 at 6:12 am #1228359

marcg-20

Hi

Thank you for your assistance in this matter the issue seems to be resolve with
reply #1225450