This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 1 month, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 21, 2019 at 2:31 pm #4432267

parisA-5

I have followed the documentation of WPML and noticed that for example I am choosing English as a language and I am in the "Offers" page but when I click on the "Contact Us" page and then click on the flags the links of the previous page stay there (the offers page). If I hit refresh while on the same page the links are refreshed and showing correctly for the contact us page.

This is my website URL

hidden link

Feel free to visit two pages and when you are on the second page just check the flag URLs, you will notice that they are showing the previously visited page URL.

As a side note I just noticed in the debug window that the wordpress memory is 40M while WPML says it needs 128MB. Not sure if this is the reason.

"Memory limit 40M A memory limit of at least 128MB is required."

Please do not disclose publicly the URL of the website I've given you

August 21, 2019 at 5:16 pm #4434181

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Before a more detailed look, please, try this basic troubleshooting:

1 - Make sure your server environment meets our minimum requirements as described at: https://wpml.org/home/minimum-requirements/, you can see your current values at your WordPress Dashboard > WPML > Support > Info menu. In your case you should make sure you have the minimum of 128M for your WordPress memory limit settings.

2 - Disable all the plugins except the WPML related ones from your WordPress Dashboard > Plugins and see if the issue is gone, if so, activate one plugin at a time untill the culprit one is found.

3 - If the issue persists, temporary change to a default WordPress theme such as the 'TwentySeventeen' theme from your WordPress Dashboard > Appearance > Themes menu.

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

Please, let me know if the steps above help to fix your issue. Have a nice day.

August 21, 2019 at 5:35 pm #4434231

parisA-5

Hi thanks for your prompt reply. I have tried all of the above and the issue persists.
Any more solutions? I am sure more users had the same problem

August 21, 2019 at 5:39 pm #4434237

parisA-5

I am using the Qode Bridge theme which is WPML compatible so that is strange.

Any chance the fact that I haven't installed everything WPML related has to do with this?

Status Active Version
WPML Multilingual CMS Installed Yes 4.2.7.1
WPML CMS Nav Not installed No n/a
WPML String Translation Installed Yes 2.10.5.1
WPML Sticky Links Not installed No n/a
WPML Translation Management Not installed No n/a
WPML Media Not installed No n/a
WooCommerce Multilingual Not installed No n/a
Gravity Forms Multilingual Not installed No n/a
Yoast SEO Multilingual Not installed No n/a

August 21, 2019 at 6:56 pm #4434781

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

August 22, 2019 at 6:42 pm #4442285

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a look in your website and diddn't notice any issue with your settings, so a new compatibility issue could be reason here.

Although the theme is listed as compatible at: https://wpml.org/documentation/theme-compatibility/?wpv_view_count=112654&dev%5B%5D=146797&wpv-theme-category=0&wpv_post_search=&wpv_filter_submit=Search in some specific cases some new compatibility issues could appear with most recent versions of WPML, this is why we need to check it in order to confirm a possible compatibility issue, for that, here are the procedures:

  • Install the theme/plugin in a clean installation and reproduce the problem in this new installation. So we can isolate it and do some testing without the interference of server settings or other plugins
  • After this, I will check the problem in this new installation and look for a quick solution
    If I can not find a solution, I will forward the problem to our compatibility team.
  • The compatibility team will do some more testing and will contact the product author to fix the issue

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the (theme/plugin) to this test install, setup it the same way as in your website (using the same options) and create some dummy content to reproduce the issue. Please note that we only need the (theme/plugin) and the related functionality, you don't need to setup a entire website or clone your existing site. The fewer plugins the better.

After that, please send us clear steps on how to see/reproduce the issue on this test install. We will run some tests.

Please, let me know when you are ready, thank you for your collaboration, have a nice day.

August 22, 2019 at 7:26 pm #4442465

parisA-5

This sounds like a lot of work for a paid plugin that should work straight out of the box.

Have you had the chance to look at the configuration? You havent logged in the account i provided.

Please this is urgent the website needs to go livr tomorrow.
Am I the first one who comes across this issue? Can you not so something?

August 22, 2019 at 8:21 pm #4442789

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a look in your settings using the provided access details, what I meant is that I didn't notice any issue related to your settings, this is why an additional investigation is needed, for that we would need to make a compatibility test and if it works in a clean test environment we should proceed with a more detailed investigation, this time using a copy of your website.

If you don't want to setup the test installation I am happy to help and make this test for you, for that, please, provide me with a copy of your theme and I will proceed right away. You can upload the theme zip folder in a file sharing service such as Google Drive, Dropbox etc and share the download url here, a private reply will be enabled so you can provide it privately. Thank you for your collaboration and understanding, have a nice day.

August 22, 2019 at 9:56 pm #4443067

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a detailed look in this issue using your provided theme and clean test sandbox environment and noticed there issue happens when you keep the 'fade' transition effect for pages from your WordPress Dashboard > Qode Options > General > Page Transition.

I recommend you to keep it disabled while our compatibility team gives a detailed look and contact the theme author to provide a fix for that. You can also contact the theme author in order to learn more if they have a workaround for that.

Please, let me know if it works for you, have a nice day.

August 29, 2019 at 7:53 pm #4483359

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

I am jumping here to let you know this ticket is now escalated to our compatibility team. Thanks.

September 5, 2019 at 2:05 pm #4519863

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for your patience while waiting for a reply. Our compatibility team has contacted the theme author regarding this issue multiple times in order to advice them of this issue, in this case you can avoid using the fade page transition effect from your WordPress Dashboard > Qode Options > General > Page Transition settings or you can contact the theme author directly regarding a fix for that. Thank you for your understanding and collaboration, have a nice day.