This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 15 replies, has 2 voices.

Last updated by Shekhar Bhandari 2 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
August 8, 2019 at 8:38 am

lisa-annP-2

Hello,

ever since I started using WPML, my website got incredibly slower. With some analysing-plugin (Query Monitor) I was able to pinpoint that it has something to do with WPML. However, I do not really know how to fix it and would love if you could check the backend to see where possible issues could be.

I have already tried following some steps (f.e. no loading of .mo, checking some boxes from the language settings, etc.) but it did not seem to help.

Thank you a lot for your assistance!

August 8, 2019 at 10:14 am #4361741

lisa-annP-2

In case this helps, here are some snippets from Query Monitor:

hidden link
hidden link

August 8, 2019 at 10:44 am #4361917

lisa-annP-2

Another update from my site:

I have deactivated the "String" Extension for WPML - and look, my site has become really fast. I think this has to do with the fact that the String Extension needs a lot of database space.

My question now: Is it possible not to have all strings registered, but only some? I need some specific ones (for example for WooCommerce), but having 34000 Entries when I only need like 300 seems a bit too much. I hope you know what I am talking about and am looking forward to your solutions.

Thanks!

August 8, 2019 at 11:29 am #4362221

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Since we discuss this issue on chat recently, I think we can close this ticket here.

Thanks

August 8, 2019 at 11:30 am #4362225

lisa-annP-2

My issue is resolved now. Thank you!

August 8, 2019 at 11:41 am #4362295

lisa-annP-2

Sorry, I've just tried following

https://wpml.org/forums/topic/how-to-find-delete-waiting-for-translations-strings/#post-1244576

and it doesn't work. It says hidden link that it doesn't find anything.. any idea? If I need to alter something in wpconfig, could you tell me where exactly?

August 8, 2019 at 11:43 am #4362305

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

That's not an issue since the query doesn't return anything there is nothing to delete.

Thanks

August 8, 2019 at 11:47 am #4362319

lisa-annP-2

Hi again, so the steps are:

1) Add those lines to wpconfig (does it matter where)?
2) Run those queries one by one (even though it doesn't delete anything, but I thought it should delete something?)
3) Do these things in WPML in the backend

?

August 8, 2019 at 11:52 am #4362325

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Add those lines to wpconfig (does it matter where)?

Before /* That's all, stop editing! Happy blogging. */ in wp-config.php

Run those queries one by one (even though it doesn't delete anything, but I thought it should delete something?)

If it doesn't delete anything, it means there are no such entries with such criteria to delete. So proceed further.

3) Do these things in WPML in the backend

Couldn't understand this, can you please explain a bit further.

Thanks

August 8, 2019 at 11:55 am #4362379

lisa-annP-2

If WP-config defines "not translated" as 3, and it says it can delete 0, it's not true because if I check the string settings (f.e. hidden link) it says there are "not translated (nicht übersetzt)" strings.. that's why it's weird to me.

3) I meant these steps:
After that visit WPML>>Support page
Click on Troubleshooting link(blue link at the bottom of page)
Then click on *Recreate ST DB cache tables* button of Clean up to recreate the string translation DB cache tables

August 8, 2019 at 11:59 am #4362395

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

You shouldn't define anything in the wp-config.php file, it looks like you added the code to the wp-config.php file as shown in the mentioned ticket, is it?

After that visit WPML>>Support page
Click on Troubleshooting link(blue link at the bottom of page)
Then click on *Recreate ST DB cache tables* button of Clean up to recreate the string translation DB cache tables

Are you not able to find these buttons?

Look forward to your reply.

Thanks

August 8, 2019 at 12:03 pm #4362565

lisa-annP-2

Yes I did, apparently there was some misunderstanding. I will remove those lines.

I can find them, I was just asking for verification in this matter.

I will try again and let you know - I'll let this ticket opened for now.

August 8, 2019 at 1:08 pm #4363157

lisa-annP-2

Hi, I'm still kind of confused.

Do I need to add these lines to wp-config.php or not?
define( 'ICL_STRING_TRANSLATION_PARTIAL', 2 );
define( 'ICL_STRING_TRANSLATION_COMPLETE', 10 );
define( 'ICL_STRING_TRANSLATION_NEEDS_UPDATE', 3 );
define( 'ICL_STRING_TRANSLATION_NOT_TRANSLATED', 0 );
define( 'ICL_STRING_TRANSLATION_WAITING_FOR_TRANSLATOR', 1 );

Thanks for letting me know.

By the way: I did the queries now and it said 0 for all of them... this can't be right.

August 9, 2019 at 3:30 am #4367093

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The ticket says
"For your updates, we are using the following definitions in our wp-config.php file to declare the status of strings. In your case, we will be using 1,3."

Which means we are adding this ourself to the plugin files and Bigul has mentioned it so you can understand that status that we are using.

Being so, it does not need to add it to the config file, it's just there to make you understand what status we use for strings in a different context.

Let me know if this helps.

Thanks

August 12, 2019 at 8:13 am #4379085

lisa-annP-2

Hello, I am not sure whether the suggested fix really did something for me. There were still many untranslated strings to be found..

However, after updating PHP 5.6.3 to 7.3 I did experience a huge increase of website speed. I think for the future, this could also be taken into account! 🙂

I will close this ticket for now, thank you.