This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 32 replies, has 2 voices.

Last updated by Toby 7 months, 1 week ago.

Assigned support staff: Sumit.

Author Posts
March 4, 2019 at 11:55 am #3268438

Toby

I am trying to:
Have equivalent attribute archives with the following urls
hidden link
hidden link

Link to a page where the issue can be seen:
hidden link

I expected to see:
Attribute archive of all products tagged with 2017 product attribute

Instead, I got:
ERR_TOO_MANY_REDIRECTS

March 4, 2019 at 2:04 pm #3269179

Toby

I just wanted to add, on a staging site I switched to Twentynineteen theme and the infinite 302 redirect loop still happened, but when I deactivated all WPML plugins, the product archive pages started to be accessible.

I also found it is not just happening on attribute archive but also product tag archive pages.

Clearly I am unable to disable WPML plugins on production website without rebuilding with a different multilingual solution – so appreciate your help with this.

March 5, 2019 at 1:50 pm #3274351

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you for contacting support forum.

We have released a new minor version of WPML. Could you please update to 4.2.4.1?
Also, I don't see a redirection loop instead I see 404 error. If the issue persists after the update then could you please let me know the exact steps to see the issue?

Thanks

March 6, 2019 at 1:28 pm #3279222

Toby

Hi Sumit, thanks for getting back to me.

Sorry the The 404 was because I changed the permalink for product attribute archives while troubleshooting. It never helped. I have now put this back to how it was originally configured.

Unfortunately the recent updates you have issued have not fixed the issue. To see the issue go to any wine page such as hidden link and click on the Vintage attribute (year) link:
hidden link

Also product tag archives have the same problem:
hidden link

We have a development server at hidden link
u: fondugue_staging
p: 8hkNtiqIyGGd

This has identical set-up, let me know if you will need access for troubleshooting?

Thanks,
Toby

March 7, 2019 at 7:39 am #3282674

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thanks for the info. I can see the issue. However, I don't understand how did you construct those URLs without product tag base.
I need to check the configuration myself so I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.
Instructions to send private information are here: hidden link

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thanks

March 7, 2019 at 12:50 pm #3284487

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Toby,

I deactivated WPML on the staging site for debugging but then I got a fatal error from WCML.
I am checking this why but FTP details are not working. I got this message

Status:	Connection established, waiting for welcome message...
Error:	Connection timed out after 20 seconds of inactivity
Error:	Could not connect to server

Could you please check the FTP details and please deactivate WCML so I can access the site.

Thanks

March 7, 2019 at 12:51 pm #3284490

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

To deactivate I will rename the WCML plugin folder. I have enabled the private reply.

March 7, 2019 at 2:29 pm #3284920

Toby

Hi Apologies about that, this was due to our deployment process previously ignoring folders called “upgrade” which was previously fixed to only ignore these folders at wp-content level, but WCML must have slipped through. This has now been fixed.

Also just checked the FTP details I sent before and they are working for me (see screengrab)

March 7, 2019 at 3:03 pm #3285080

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Toby,

Thanks for the information.

I have reproduced the issue and this has been reported to developers. I will update you as soon as the issue is fixed.

Problem and workaround
The problem is related to numeric slug. When you have a tag, attribute with numeric value like 2018 and 2017 the issue happens.
As a workaround, you can change the slug e.g. to 2k18 and keep the name as it is 2018 this will work. If you are willing to keep the numeric slug only then please wait till this issue is fixed I will update you as soon as I have information.

Thank you for your patience.

March 7, 2019 at 3:12 pm #3285168

Toby

Thanks Sumit.

As this URL is indexed with Google (Their webmaster tools alerted us to it being broken) I am reluctant to change the URL.

That said if the fix will be weeks away then it may be beneficial changing the urls and adding 301 redirects.

What do you recommend?

March 8, 2019 at 10:07 am #3291012

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi, Let me please confirm with the developers.

March 8, 2019 at 10:10 am #3291032

Toby

Thank you Sumit 🙂

March 8, 2019 at 1:32 pm #3292622

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

The fix may take time so our team has provided a temporary workaround.
Please follow these steps:-
#1 Create complete backup of site files and database
#2 Go to file \sitepress-multilingual-cms\classes\query-filtering\class-wpml-query-parser.php line number 280
#3 And replace this line

if ( $translated_slugs && $slug !== $translated_slugs[0] ) {

with

if ( $translated_slugs && $slug != $translated_slugs[0] ) {

#4 Then visit the URL in private or incognito browser made

Does it fix the issue? If you have any difficulty to make these changes then please let me know I will make it.

Thanks

March 8, 2019 at 5:10 pm #3294614

Toby

Thank you that is much better.

Any ideas why the 2016 french archives says “Voici les 2 résultats” and yet no products appear?
The two 2016 wines are sold out but would still like them to appear in the archives if possible: hidden link

Also is it possible for the french slug to be the same as the english one? (eg. 2016 without the -fr at the end)

Thanks again

March 11, 2019 at 9:07 am #3308925

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Toby,

That's good. 🙂 About the archive page, I am sure there must be settings in WooCommerce which I couldn't find right now but you can check with the WooCommerce support.

About keeping the same slug, this is upcoming WPML feature. Maybe in the next version. But for now, we have a workaround you can keep the same term slug using quick edit.

#1 Translate the term, as usual, you will see language code appended automatically
#2 Edit the terms using quick edit and remove the language code then save.

Hope it helps.

Thanks