Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Bruno 3 months, 3 weeks ago.

Assigned support staff: Bruno.

Author Posts
May 8, 2019 at 1:12 pm #3767073

severinP

Opening a new thread about an old bug that wasn't resolved

https://wpml.org/forums/topic/infinite-loop-when-two-tabs-have-different-languages/

I just DDos'ed my own website like this, I had 5 tabs open in the background, went browsing on other tabs and didn't really pay attention all 5 tabs sent one request per second (total of 5 request per second), the website is quite heavy (because of wpml actually) so the load was phenomenal.. Had to restart the server to resume normal load.

The big problem is that the requests are done even if you're not on the page...
It's really a problem because even non logged in users can do this and unintentionally DDos a website

May 8, 2019 at 5:23 pm #3769525

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Can you sign in to your site?

If so, please, what is the version of WPML and WP are you using? I would like to know more about your installation. Can you please provide your WPML Debug information in the debug field below? http://wpml.org/faq/provide-debug-information-faster-support/

Also, please as a test, could you disable all non-WPML plugins, switch to the default theme and see if the problem persists?

If the problem is fixed, please, enable the plugins one by one to see if there is any compatibility problem between these plugins.

Thank you.

May 8, 2019 at 5:57 pm #3769699

severinP

To answer your questions, the latest for everything

And yes, the problem persists with just Woocommerce + WCML

Just look at the other thread, there is all the needed information to reproduce

May 8, 2019 at 9:22 pm #3771227

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Sure. I was able to replicate the problem you are reporting. I've forwarded your ticket to our developers and after reviewing, we'll contact you.

Note that at this point I have no workaround for this. If our developers create a workaround for this, I'll let you know.

Thank you.

July 31, 2019 at 10:35 pm #4317785

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Sorry for the delay. Just to update this ticket, our developers think this is normal and there is nothing we can do about it. The issue is related to WC recalculating mini cart so it's expected action.

Thank you.