This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

No supporters are available to work today on this forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 12 replies, has 2 voices.

Last updated by Radu 5 months, 2 weeks ago.

Assigned support staff: Radu.

Author Posts
April 24, 2019 at 11:56 am #3672291

alekseiS-2

Hello Sirs,
I am trying to translate my theme which do work with your plugin. But WPML for some reasons treat that the initial strings are in Russian in my case but they are in English in fact. So I can not translate it.

Select for which domain to set the language:
This domain currently has the following strings:

Current source language
Number of strings

Russian
442
Apply

But there is no Russian translation of the theme at all. Everything is in English there

April 24, 2019 at 12:20 pm #3672629

alekseiS-2

PS Other lang could not be checked to be a new source...

April 24, 2019 at 12:49 pm #3672985

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Aleksei,

Thank you for reaching out the WPML support!

I think that you can easily do the change you're looking for by going to Dashboard → WPML → String Translation. Here, just simply select the strings that you'd like to change their original language and, once you're done, go to the end of the table and use the Change the language of selected strings option. This way you'll be able to set the English language for the selected strings. Can you give this a try and tell me if this is what you were looking for, please?

Thanks,
Radu

April 24, 2019 at 1:03 pm #3673215

alekseiS-2

My issue is resolved now. Thank you!

April 24, 2019 at 1:30 pm #3673433

alekseiS-2

Initial string lang is changed, but translations does not affect the front end page now.

April 25, 2019 at 10:14 am #3681051

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Aleksei,

Is there any chance that you could attach a link to a page where you have this problem with the strings, please? Also, it would be great if you'd give me access to the dashboard area too. This way I'll be able to check things out a bit closer and see what's going on. Don't worry, I set the next message to be private so the credentials can be seen just by you and me.

Thanks,
Radu

April 25, 2019 at 10:57 am #3681369

alekseiS-2

Sorry but the Upload an image button does not work for me on your site.

This is three pictures that I placed on my hosting especially for you to show.
hidden link - that what I want to translate
hidden link - this is the theme file of the page part
hidden link - this is the screenshot of WPML plugin with the string translation.
You can also have a look at the page in original: hidden link

April 26, 2019 at 7:59 am #3688617

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Aleksei,

Please give me access to the dashboard area of the website and I'll check this out a bit closer too see why is the text not translated (even though you made the changes in String Translation). I'm sure we'll find out what's going on.

Thanks,
Radu

April 26, 2019 at 11:53 am #3690467

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Aleksei,

Can you check the username and password, please? I just tried to use them and I get a message that one of them is wrong.

Thanks,
Radu

April 26, 2019 at 12:25 pm #3690601

alekseiS-2

Sorry, I've changed the user and password and I have checked it.

They are in the private massage upper. It is updated.

April 29, 2019 at 7:59 am #3700779

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Aleksei,

Can you check again the post you send to me (hidden link) and have a look at the No comments text, please? You can see that it's translated now. All I had to do is go to Dashboard → WPML → String translation and search for this text. This seems to be in two different places and I just made sure that both of them have the Translation is complete box checked (the second one wasn't checked). Can you check this out, please?

Thanks,
Radu

May 2, 2019 at 6:27 am #3722079

alekseiS-2

It works but partly. I can not translate the fraise

Notify me when new comments are added.

At the bottom of the article on hidden link

It is translated, saved and the cach has been cleaned

May 6, 2019 at 12:30 pm #3748323

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Aleksei,

I checked this text and I could see that this is set by going to Dashboard → Settings → Lightweight Subscribe To Comments. The values set on these fields are saved to the database. In this case, I had to add this little code:

<wpml-config>
  <admin-texts>
    <key name="lstc">
      <key name="message"/>
      <key name="label"/>
      <key name="subject"/>
      <key name="thankyou"/>
      <key name="ty_subject"/>
      <key name="ty_message"/>
    </key>
  </admin-texts>
</wpml-config>

to Dashboard → WPML → Settings → Custom XML Configuration tab. Now, you can go to Dashboard → WPML → String Translation and do the translations. I did this for the Notify me when new comments are added. text. Please let me know how it looks now.

Thanks,
Radu

The topic ‘[Closed] Initial lang in strings is wrong.’ is closed to new replies.