Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 7.85 hours from now. Thank you for your understanding.

This topic contains 11 replies, has 2 voices.

Last updated by serhiiK-7 1 month, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
July 30, 2022 at 10:42 am #11770553

serhiiK-7

Hello,
do you work today?
I need help.
I installed WPML and start work
But I have problem with WPML Media Translation. This plugin installed, activated but not start work. I see message:
\"For WPML Media Translation to be fully functional, you need to do this setup again. It will only take a few seconds depending on the total number of posts in your WordPress installation\". Finish setup
I click the buttom \"Finish setup\" but anything change.

2.png
1.png
July 30, 2022 at 6:15 pm #11771445

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there.

From what I can see in the debug information that you sent, there are 3 caching plugins that you have installed on your site, plus another multilingual plugin (locotranslate) and many other plugins.

By the way, it is not recommended to have multiple multilingual plugins active at the same time.

So let's try this:

- create a full website backup
- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

If you have the chance, it would be best to do this in a staging (testing) environment.

Please let me know how that goes and if following any of these steps solved your issue or brought any change.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

July 30, 2022 at 7:40 pm #11771547

serhiiK-7

Thank you for answer. I have found conflict with LearnPress plugin. This plugin need me. I can't delete it. Is there any way to eliminate this conflict or will I have to deactivate WPML Media?

July 31, 2022 at 7:18 am #11772463

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there and welcome back.

You can try this: deactivate Learnpress, make sure then that you go through the WPML Media setup, then, after you finish, re-activate LearnPress.

It seems that the LearnPress plugin is not 100% compatible with WPML yet, as you can see from their developers' response here:
https://wordpress.org/support/topic/is-learnpress-100-compatible-with-wpml/

I hope that this information helps 🙂

Mihai

July 31, 2022 at 9:35 am #11772757

serhiiK-7

I did it. WPML Media has been successfully installed and activated. But when I have activated LearnPress again it stopped work. The image selection function for the translation page has stopped working. Is there another way or is this not a solvable problem at the moment?

Serhii

WPML media.jpg
July 31, 2022 at 9:47 am #11772801
serhiiK-7

And one more post. One more question. Since I am just learning how to use WPML, I did not find how to translate the header, footer and copyright area of the site. I didn't find anywhere how to do it. Can you help me and show option how this can be done?

New threads created by Mihai Apetrei and linked to this one are listed below:

https://wpml.org/forums/topic/split-how-to-translate-the-header-footer-and-copyright-area-of-the-site/

head and footer.jpg
July 31, 2022 at 10:20 pm #11773807

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Serhii and welcome back.

In regards to the TranslatePress plugin conflict, unfortunately, as long as that plugin is not fully compatible with WPML, I would recommend that you get in touch with their support team and see if their devs have a solution for this.

You can also recommend them to join our 'Go Global' program (https://wpml.org/documentation/theme-compatibility/go-global-program/) where our Compatibility developers will help them make their product 100% compatible with WPML for free.

From my understanding, there's also a different question that you have where you would need our help.

Per our Support Policy, we can handle only one issue per ticket.

Continuing with one issue per ticket helps not only supporters to focus on one issue at once, but also enables other users to find solutions to their questions faster.

So I created this new ticket for you here (https://wpml.org/forums/topic/split-how-to-translate-the-header-footer-and-copyright-area-of-the-site/) in regards to the new question that you asked and I will get back to you about this on that new ticket.

Thank you for your understanding.

Mihai

August 1, 2022 at 4:34 am #11774209

serhiiK-7

Hi, Mihai

Ok, I understood.
I won't close this thread just yet. I'll post later if the issue will resolved.

And for some reason I can't reply in this new thread: https://wpml.org/forums/topic/split-how-to-translate-the-header-footer-and-copyright-area-of-the-site/

So I'm answering here. Yes, I will write about the result when I try the recommendations you suggested.

Best,
Serhii

August 2, 2022 at 10:06 am #11784169

serhiiK-7

Hi, Mihai

I solved the problem in other way. Just started upload images manually when the page already have translated.

So I think this topic can be closed as solved.

August 2, 2022 at 1:02 pm #11785857

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the update, Serhii.

Then, can you please mark this current ticket as resolved?

Thank you very much.

Mihai

August 2, 2022 at 4:22 pm #11787323

serhiiK-7

Yes, I mark it as resolved.

August 2, 2022 at 4:25 pm #11787325

serhiiK-7

My issue is resolved now. Thank you!