Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.42 hours from now. Thank you for your understanding.

Author Posts
December 13, 2017 at 11:51 am

guillaumeF-8

Put simply, many buttons on the backend are not clickable anymore once WPML is installed. Disabling WPML translation management re-enables those buttons, still, anything related to WPML is half broken. I cannot delete/add languages. I can't make a copy of a given page in another language to start working on it (I instead have a blank page) and so on...

Help!

December 14, 2017 at 3:50 pm #1458099

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello,
Thank you for contacting WPML support.

1.- Please follow this steps to isolate the cause of this issue:
- Check if there is any JS error in the JS Console.
- Make a full backup of the site for security reasons.
- Update all outdated plugins and themes if corresponds.
- Flush all cache memory.
- If the issue persists deactivate all plugins except WPML plugins.
- Activate a default WordPress theme like Twenty Seventeen.
- If the issue dissapeared start activating the theme and then the plugins one by one until you see the issue again.

Please let me know the result of this steps.

2.- Please double check the WP credentials in your previous message, I couldn't log into the site.

Kind regards,
Carlos

December 15, 2017 at 9:50 am #1458714

guillaumeF-8

Hello Carlos,

Thanks for getting back to me. I enabled the account I previously shared with you, credentials are the same, should be working now.

Apparently, it seems that the broken buttons I was talking about are working again after disabling the WPML translation management plugin. Still, even after that I cannot change the languages, and even though it seems I can create pages, I cannot copy them in other language and build upon that.

I don't think there's any issue with the JS as someone look into that recently.

What about Jquery? Sorry I'm not all that knowledgeable in that area, I just know that this needs to be updated. Could it create issues?

Thanks again for your time and help

December 15, 2017 at 2:43 pm #1459035

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Guillaume,

1.- Before we continue I need to ask you to update all outdated plugins and themes. Outdated functionalities can cause conflicts in the code.

2.- Once all plugins and themes are updated, if the issue persists follow this steps:
- Make a full backup of the site for security reasons.
- Deactivate all plugins except WPML plugins.
- Flush all cache memory.
- Activate a default WordPress theme like Twenty Seventeen.
- If the issue dissapeared start activating the theme and then the plugins one by one until you see the issue again.

Please let me know the result of this steps.

Regards,
Carlos

December 15, 2017 at 2:56 pm #1459057

guillaumeF-8

Hi Carlos,

I did just that, and it seems the issues are coming from the String Translation or translation management plugins. Though sometimes some buttons seem to work, sometimes they don't. I tried to reinstall everything, I cannot even clicl on the "next" button when I first setup wpml (where I select the languages).

I really don't know hat else to do!

I gave you access to the backend, did you find time to look at it?

December 15, 2017 at 3:05 pm #1459069

guillaumeF-8

I'm trying to find ways around the issues of non-clickable buttons (or things like the impossibility to create a new page (new language) starting with a copy of same page in language of origin, but there's always a page where I'll be stuck. WP Menus Sync page doesn't work, even the buttons on the troubleshooting page do not work either... The website start functioning again when I get rid of everything WPML related basically 🙁

December 15, 2017 at 3:17 pm #1459090

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Guillaume,

I would like to ask your authorization to make a copy of the site in order to make further tests on a local environment without affecting the live site.

Regards,
Carlos

December 15, 2017 at 3:21 pm #1459094

guillaumeF-8

Of course. Anything I need to do to help you with that ?

December 15, 2017 at 5:40 pm #1459223

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

Please disable 'Real-Time Find and Replace' plugin -> Flush all cache memory -> Check if the issue persists.

Looking forward to your answer.
Regards,
Carlos