This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 12 replies, has 2 voices.

Last updated by Yvette 1 month, 1 week ago.

Assigned support staff: Yvette.

Author Posts
August 14, 2019 at 6:35 am #4392729

viktorL-6

I am trying to:

Link to a page where the issue can be seen:
hidden link
Check to link udner Carbon Sandwich ("Mehr Dazu")

I expected to see: Linking to German version of the page

Instead, I got: Linking to default (English) version of the page

August 14, 2019 at 3:31 pm #4396387

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I will be helping you with this.

Are you using the WPML classic translation editor to create the translations?

If so, please go to WPML > Settings > Custom XML Configuration and add the following XML code just before the </wpml-config> closing tag and save:

<shortcodes>
    <shortcode>
        <tag>et_pb_button</tag>
        <attributes>
            <attribute>button_text</attribute>
            <attribute>button_url</attribute>
        </attributes>
    </shortcode>
</shortcodes> 

After that, go to the edit screen of the page (original language), make a small modification on the content (like adding a dot or comma) and save. Now go to the Translation Editor, the link field should be displayed now.

Please let me know if it worked for you.

August 15, 2019 at 2:13 am #4398271

viktorL-6

Hello Yvette,
We have translation manager installed, but are translating right into Divi WYSIWYG editor in each language.

August 15, 2019 at 4:14 pm #4402321

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

In this case, if you update the button link within the wisywig of the translated post, does it not save to the database?

If not, can you please send me access to your site in the private area and indicate which page has this issue?

Thanks

August 16, 2019 at 4:55 am #4404683

viktorL-6

Hello Yvette,
If we manually add the language prefix ("/ja/xxx") then it works, but this is what we want to avoid. The link should lead to the language version the user is browsing.

August 16, 2019 at 8:34 am #4405439

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

With DIVI button, as this is considered user-provided content, it has to be translated at some point.

If you are using the Translation Editor, the XML code I provided earlier will allow it to appear and be available for translation within the editor. IF you are not using the Translation Editor, then you will have to enter the new URL manually or by selecting the page from a dropdown if the link points to internal website content.

I understand from your comment that you are expecting WPML to "sense" an internal URL and then translate the URL to point to the translated version of the page/object it is pointing to in the original language.

Is my understanding correct?

August 19, 2019 at 4:28 am #4413559

viktorL-6

Yes, that is correct. I expect the linking to be taken care of for internal pages and not have to manually edit to add /lang/. Is that possible?

August 19, 2019 at 1:56 pm #4416659

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hmmm. I was under the impression that we do that automatically ... if something was missed you can go to WPML -> Settings and click "Translate Link Targets"

Can you try this and let me know?

August 29, 2019 at 7:10 am #4478147

viktorL-6

We can't get this working. Please assist further. Previously links in Divi buttons automatically linked to the correct language, not to fallback language.

August 29, 2019 at 9:35 am #4479277

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I setup a sandbox site with the latest DIVI theme installed.

Here, I did the following steps:
- Transalted the "Sample Page" to second language
- Created a new page which included only a Button element with the URL pointing to the "Sample page"
- Duplicated this new page to the 2nd language and then "translate independently"
- I then checked the internal link of the button on the translated page and I confirm it is changed automatically to point to the "Sample Spanish Page".

So, in this sandbox site, it seems that everything workign as expected.

Here is login access to it:
hidden link

Here is the URLs of the example I described:
hidden link
hidden link

Are you able to replicate the behaviour of your site on this sandbox install?

August 29, 2019 at 10:15 am #4479849

viktorL-6

Can I provide you with access to our test environment for you to have a look?

August 29, 2019 at 10:21 am #4479929

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Sure.

I am opening the private area for this information.

September 3, 2019 at 10:18 am #4503419

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi

I executed the same steps as I did on the sandbox site and got the same results. You can check it here:
hidden link

In both cases, I first duplicated the page and then "translated independently".

I did notice that you did not have String Tranlsation module activated on your test site. I first activated the String Translation module which woudl have been needed to create the correct package strings for translation.

Are you now able to create a simple example case where the internal links are not translating?

The topic ‘[Closed] Internal links goes back to default language’ is closed to new replies.