This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to translate links using Advanced Translation Editor

Solution: Links cannot be translated using the ATE. Switching to the classic translation editor resolved the issue.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by willem Buijze 2 weeks, 2 days ago.

Assigned support staff: Lauren.

Author Posts
September 27, 2019 at 4:22 pm #4655863

willem Buijze

I am using WP Bakery page builder. Have some images with internal links. However in translations they keep pointing to the main language (English). I run several times:

Solution: - Go to WPML->Settings-> Translate Link Targets -> and click on "Scan now and adjust links".

Did not work.

Also put in Custom XML configuration the following:
<wpml-config>
<shortcodes>
<shortcode>
<tag>jtl_image</tag>
<attributes>
<attribute type="link" encoding="vc_link">link</attribute>
<attribute type="media-ids">image</attribute>
</attributes>
</shortcode>
</shortcodes>
</wpml-config>

Did not resolve anything.

Read many, many topics in your support area. But I can not find the solution. And probabaly I am not the only one with this problem.

hidden link

Can you please help me?
Thank you,

Willem

September 27, 2019 at 5:35 pm #4656241

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

September 27, 2019 at 8:43 pm #4656747

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending access. Are you trying to translate the links for images at the bottom of the homepage? If so, I have added the following to your custom xml configuratin:

<shortcode>
            <tag>vc_single_image</tag>
            <attributes>
                <attribute>link</attribute>
            </attributes>
        </shortcode>

HOwever, I notice that you are using the Advanced Translation Editor, and the ATE does not display links because it removes the HTML. So, in order to translate these links, you will need to switch to the classic editor. You can change that in WPML -> Settings.

Please let me know if you need any further assistance and I will be happy to help.

September 28, 2019 at 2:22 pm #4658463

willem Buijze

Laura,
Thank you for your help but after your last writing I do have a few questions more:
1 - If I switch back to the classic editor, do I lose the current translations made by ATE or everything stays as it is?
2 - if I switch back to the classic editor, the internal links in the images will be done correctly?
3 - Can I then switch back to ATE? Or do I lose the internal links right away?

The thing is: I really like the new ATE, in my opinion, it is much better than the classic one. But images with internal links are important for the website.

So, is there a chance that the ATE will be updated soon?

Waiting for your reply,

Kind regards,
Willem

September 30, 2019 at 2:33 pm #4665329

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I recommend first marking the translation as 100% complete in ATE before changing the editor. That way, anything that has already been translated will be published and saved. Then, switch to Classic to update the links. If you prefer to switch back to ATE, I recommend the same, make sure that the classic editor translation is marked 100%. I have seen some issues when going back and forth between editors, most commonly being that the strings do not publish on the front end. In this case, you can usually mark them complete in the string translation table or delete them from the string translation table and resave the translation via the editor.

There is an internal task to add links to the ATE but I don't know if it will be implemented for sure. That will be decided by our development team.

September 30, 2019 at 5:25 pm #4666839

willem Buijze

My issue is not resolved for 100%, but I know the steps to follow. However, it would be much easier if ATE would handle this on its own...Thank you.