Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Carlos Rojas 1 month, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
December 13, 2019 at 11:38 am #5123029

Chris

Hi !!

I have a site that uses two versions of English - en-uk and en-us.

The pages are translated and work perfectly using the flags to navigate.

The blog posts on my site are not translated, so I have set them to:

Translatable - use translation if available or fallback to default language (In the settings page)

This works as long as the post links I click are dynamic, EG in the blog listing page, similar posts lists etc etc

The problem I am having is that if I have a blog page that has a link inside it, eg... link to another post... it takes me back to the main version.

hidden link

December 14, 2019 at 11:59 am #5129303

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello,
Thank you for contacting WPML support.

If the posts are not translated then the links added in the body of the post won't be translated neither. You need to translate or duplicate the posts in order to be able to 'translate' the links.

Please let me know if you need further assistance.
Kind regards,
Carlos