Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
If you're experiencing an Internal Server Error when clicking through links on translated version of your website, the issue might be related to the .htaccess file or permalink settings.
Solution:
We recommend trying the following steps:
1. Visit the following documentation: https://wpml.org/errata/htaccess-is-rewritten-with-language-folder/
2. Re-save your permalinks by going to Settings >> Permalinks in your WordPress dashboard and clicking the 'Save Changes' button.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.93 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 1 reply, has 2 voices.

Last updated by Noman 4 months, 2 weeks ago.

Assisted by: Noman.

Author Posts
November 26, 2023 at 3:14 am #14923683

maciejK-26

Link to a page where the issue can be seen: hidden link

Please note that this error does not happen on main 'english' version website: slavicherbs.com

When clicking through links on the 'polish' translated website I get this error:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at [no address given] to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

slavicherbspl_Screenshot 2023-11-25 221218.png
November 26, 2023 at 8:34 am #14923891

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Based on the details you provided, it appears that the issue may be related to specific plugins or themes on your site. To address this, could you please try the workaround mentioned in this link: https://wpml.org/errata/htaccess-is-rewritten-with-language-folder/

And please re-save permalinks from the Settings >> Permalinks page by pressing the Save Changes button and see if this resolves your issue.

Thank you

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.