This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by linkeyparma 4 months, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
May 22, 2019 at 9:19 am

linkeyparma

I am trying to: run my website with WPML Multilingual CMS activated

Link to a page where the issue can be seen: hidden link

I expected to see: The website should work normally if WPML Multilingual CMS is activated

Instead, I got: if WPML Multilingual CMS is activated I receive an Internal server error and I cannot see the majority of the pages of my website.

At the moment I have disabled the plugin.

The website is currently under development.

This is the error message that I find hundreds of times in the website logs:
[Wed May 22 01:26:50 2019] [error] [client 157.55.39.147] [host hidden link; AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.

May 22, 2019 at 9:45 am #3863837

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

This ismoething you have to check this with your server support.
This is related to some rulles in your .htaccess
Please refer the accepted answer here: https://stackoverflow.com/questions/22756796/apache-2-4-request-exceeded-the-limit-of-10-internal-redirects-due-to-probable

If you do not know how to check this please show this to your server company.
They will be able to fix this in minutes.

Also, your WP Memory limit is just 40MB which is not enough.
Please increase it.
Your hosting allows you to have upto 512 MB

Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');

Let me know how it goes.

Regards,
Riffaz.

May 22, 2019 at 10:18 am #3864161

linkeyparma

Hello Riffaz,

I have changed the code of wp-config as you requested but I still get this message whenever I nagivate to a page:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at postmasterwww.emilyhome.it to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Strangely, I don't see new error messages in my logs.

Are there other tests we can do about this issue ?

Thank you.

May 22, 2019 at 10:32 am #3864359

linkeyparma

This is the content of my .htacess

#This Apache config file was created by Duplicator Installer on 2019-03-20 20:28:32.
#The original can be found in archived file with the name htaccess.orig
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

The article on stackoverflow you mentioned, is about lines that do not exist in my .htacess.
Which are the lines to be modified in my case ?

Thank you

May 22, 2019 at 10:46 am #3864473

linkeyparma

I have verified that the error message is still shown in my logs:


[Wed May 22 12:04:52 2019] [error] [client 79.9.243.136] [host
hidden link; AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: hidden link

These logs are evidently not in real time.

May 22, 2019 at 11:10 am #3864637

linkeyparma

I tried to change my .htaccess in this way

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^ index.php [QSA,L]
</IfModule>

It does not work anyway. The first time I access to a page I can see its content. When I navigate to another page I get the Internal Server Error message.

May 22, 2019 at 11:13 am #3864667

linkeyparma

The following code does not work either:

<IfModule mod_rewrite.c>
  RewriteEngine On
  RewriteBase /
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteRule ^(.*)$ index.php?url=$1 [QSA,L]
</IfModule>

After 2-3 clicks on links to different pages, I get the Internal Server Error

May 22, 2019 at 1:43 pm #3866267

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

Please disable the WPML temporarily.
Then check the issue.

Do you see the same 500 error after this?

Let me know please.

Regards,

May 22, 2019 at 2:02 pm #3866441

linkeyparma

Hello Riffaz,

if I deactivate the plugin "WPML Multilingual CMS" the problem disappears.

Stefano

May 22, 2019 at 2:07 pm #3866455

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

Your WP Memory limit is 40MB hidden link which is not enough to handle the string translation.
Anyhow, your hosting package allows to use upto 512 MB

Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '512M');

or if you have WP_MEMORY_LIMIT is already set in wp-config.php just change the values.

Then check the issue.

Let me know how it goes.

Regards,

May 22, 2019 at 2:33 pm #3866717

linkeyparma

Hello Riffaz,

I have updated the file wp-config as you requested but the error is still there.

Stefano

May 23, 2019 at 5:51 am #3871307

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

When I go to your admin pages I see still your WP Memory is just 40MB : hidden link and this is your wp-config.php : hidden link
I do not see anywhere you defined the WP Memory.

Please define the WP Memory as I explained in https://wpml.org/forums/topic/internal-server-error-if-wpml-multilingual-cms-is-activated-in-sofani-theme/#post-3866455
This is something related to WordPress, hosting. not to any plugin.
After updating the WP Memory limit check the issue and let me know, please.

Regards,

May 23, 2019 at 6:40 am #3871483

linkeyparma

Hello Riffaz,

I have found a different piece of code to add to wp-config.php in order to raise the memory limit:

define( 'WP_MEMORY_LIMIT', '512M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

ini_set( 'memory_limit', '512M' );

This time the memory limit has been successfully rised to 512MB.

The error anyway is still there. If you click to any link on pages for more than 2-3 times the Internal Server error message pops up.

Stefano

May 23, 2019 at 7:23 am #3872015

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Is this a migrated site from somewhere?

Re-saving permalinks in Setting > permalink solves this issue.
You can check on by clicking on links.

Hopefully, this is fixed now.

Regards,

May 23, 2019 at 7:57 am #3872193

linkeyparma

Hello Riffaz,

some 8 hours ago I restored a copy of the website I had saved earlier with Duplicator.

I have seen that you have changed the Language URL Format property to

Language name added as a parameter

I would anyway need to keep the previous configuration to:


Different languages in directories ((
hidden link - Italian, hidden link - English))

If I switch to the latter selection and then re-save the permalinks, the error appears again.

Stefano